Einrichten eines Linuxclients auf Dell-PC

Liebe Linuxmuster.nette Community,

da AixConcept wohl doch nicht so schnell auf uns zu kommt, hatte ich mir gedacht, versuche ich doch mal wieder linuxmuster an die Schulleitung zu bringen, diesmal aber in v7. Unser Netz ist so schrecklich, da würde ich lieber AixConcept aktzeptieren, und das sagt glaube ich schon alles. Aber es ist wieder Hoffnung vorhanden, dass es doch linuxmuster werden könnte. Also los geht es mit der Arbeit!

Zum Ist-Zustand:
Firewall und Server laufen, Erstkonfiguration abgeschlossen, Update erledigt, Benutzer- und Rechneraufnahme getestet, scheint zu funktionieren. Admin PC mit Xubuntu läuft, hat Internet und kann sich auf den Server schalten. Jetzt aber habe ich aber Probleme beim Einrichten eines Linux Client.

Problem:
server ~ # linuxmuster-client list-available
funktioniert nicht, es kommt die Meldung: linuxmuster-client nicht bekannt. Habe versucht das Paket linuxmuster-client-servertools zu installieren, leider auch nicht bekannt. Ist die Anleitung noch nicht angepasst, oder habe ich evtl. etwas vergessen oder verhunzt?

Gruß
Rolf

Hallo Rolf,

Problem:
server ~ # linuxmuster-client list-available
funktioniert nicht, es kommt die Meldung: linuxmuster-client nicht
bekannt. Habe versucht das Paket linuxmuster-client-servertools zu
installieren, leider auch nicht bekannt. Ist die Anleitung noch nicht
angepasst, oder habe ich evtl. etwas vergessen oder verhunzt?

derzeit wird das Default cloop für die lmn7 noch von mir direkt verteilt
(sorry: wir arbeiten dran).
Du hattest also „keine Chance“ ohne hier hin zu schreiben :slight_smile:

Jetzt hab ich aber gerade gemerkt, dass ich das cloop in der Nextcloud
gelöscht hatte … dumme Idee.
Ich lad es hoch und schreib dir in ein paar Stunden den Link hier in den
Tread.

LG

Holger

Hallo,

Ich lad es hoch und schreib dir in ein paar Stunden den Link hier in den
Tread.

hier ist der Link:

ca. 7,8 GB
Gültig für 2 Wochen.

LG

Holger

Danke, lade gerade.

Hallo Holger,

Zitat aus aus der readme.txt:

„Dies ist das erste linuxmuster default.cloop für die lmn7
Es ist NICHT für die lmn62 geeignet!

Das cloop funktioniert grundsätzlich nur, wenn man auch den dazugehörigen postsync mitverwendet!
Also die .postsync Datei UND das gesammte Verzeichnis /srv/linbo/linuxmuster-client/ …“

Ich möchte das cloop nicht produktiv unter 6.2 verwenden, würde es aber gerne kennenlernen und die für meine Schule noch erforderlichen Anpassungen vornehmen, ohne dass eine Domänenaufnahme stattfindet. Im Prinzip würde ich also nur mit lokaler Anmeldung arbeiten. Schön wäre natürlich, wenn die zusätzlichen Modifikationen erhalten bleiben könnten und dann letztendlich in ein produktiv verwendbares cloop für die 7.0 münden würden.
Ist dieses Vorgehen zum Scheitern verurteilt oder ist es ein gangbarer Weg, um zu mindest clientseitig für den Umstieg auf die 7.0 gut gerüstet zu sein?

Viele Grüße

Wilfried

Hallo Wilfried,

Ich möchte das cloop nicht produktiv unter 6.2 verwenden, würde es aber
gerne kennenlernen und die für meine Schule noch erforderlichen
Anpassungen vornehmen, ohne dass eine Domänenaufnahme stattfindet. Im
Prinzip würde ich also nur mit lokaler Anmeldung arbeiten. Schön wäre
natürlich, wenn die zusätzlichen Modifikationen erhalten bleiben könnten
und dann letztendlich in ein produktiv verwendbares cloop für die 7.0
münden würden.
Ist dieses Vorgehen zum Scheitern verurteilt oder ist es ein gangbarer
Weg, um zu mindest clientseitig für den Umstieg auf die 7.0 gut gerüstet
zu sein?

natürlich kannst du das cloop in deiner 6.2 Umgebung kolonen und dann
mit lokalem Nutzer erwenden und Anpassungen rein machen und dann irgend
wann in die lmn7 an deiner Schule integrieren.
Das sollte schon klappen.

LG

Holger

Hallo Holger,

das ist eine gute Nachricht für mich. So kann ich den Client in aller Ruhe entwickeln.

Viele Grüße

Wilfried

Ein kleiner Fehler im readme Punkt 6:
chmod 644 bionic.cloop müsste wohl eigentlich chmod 664 bionic.cloop heißen.

Hänge noch vor Punkt 9 habe aber den Befehl jetzt zu Hause gefunden für das Partionieren und Syncen. In der Schule findet man ja gefühlt nie das Richtige, kann die SuS jetzt noch besser verstehen ;).

# linbo-remote -i R110L01 -p partition,format,initcache:torrent,sync:1,start:1

Damit sollte es dann hoffentlich klappen

Hallo Rolf,

Ein kleiner Fehler im readme Punkt 6:
chmod 644 bionic.cloop müsste wohl eigentlich chmod 664 bionic.cloop heißen.

Danke: habs verbessert.

Hänge noch vor Punkt 9 habe aber den Befehl jetzt zu Hause gefunden für
das Partionieren und Syncen. In der Schule findet man ja gefühlt nie das
Richtige, kann die SuS jetzt noch besser verstehen ;).
linbo-remote -i R110L01 -p
partition,format,initcache:torrent,sync:1,start:1

Damit sollte es dann hoffentlich klappen

Besitzen deine Rechnernamen tatsächlich Großbuchstaben?
Ich nehme immer nur Kleinbuchstaben.

Zu deinem Befehl:
erstmal ist partition und format redundant: es reicht format, wenn es
ohne Zahl angegeben wird, dann wir auch partitioniert.

Die Angabe von torrent bei initcache ist nur nötig, wenn du ein Befüllen
des Caches haben willst, das von der Angabe in der start.conf abweicht.
Normalerweise nimmt man aber immer torrent: damit ist das :torrent auch
entbehrlich.
Überhaupt kannst du initcache auch weglassen: der sync zieht sowiso das
Image, wenn es noch nciht im cache liegt.

Generell zum Befehl: willst du das einmal verwenden, oder soll das den
normalen sync abbilden?
Dann würde ich mir das format und initcache schenken: sonst wird
jedesmal das Image wieder über das Netz geladen: das will man ja
eigentlich gerade nicht.

und zuletzt, das -p
Das bewirkt, dass der Cleint beim nächsten Boot die Befehle ausführt.
Eine gute Möglichkeit um sicher zu stellen, dass das gemacht wird.

Ich mache das anders: ich wecke die Cleints einmal und gebe ihnen für
den Start einen Befehl.
Nachteil bei -p ist: normalerweise sitzt dann jemand vor dem Rechner und
wartet …

Meine standardtzeile ist:
linbo-remote -w 55 -r r100 -c format,sync:1,sync:2,halt

LG

Holger

Leider funktionieren beide Befehle nicht. Bei -w starten die Clients aber es wird das alte Windows gestartet oder no boootable Device angezeigt, bei den Clients die ich vorher von ihrem Betriebssystem befreit habe.
Wenn ich per PXE boote wird angezeigt:
Client IP: 10.0.110.1 MASK: 255.255.0.0 DHCP IP: 10.0.0.1
Gateway IP: 10.0.0.254
und weiter geht es nicht.

Wo kann ich nach dem Fehler suchen?

Ich bin weiter auf Fehlersuche gegangen.

Ich habe ein paar Dell Rechner (OptiPlex 9010) mit denen ich einen Probe-Raum für das neue Netzwerk einrichten wollte. Habe mir nun noch einen Fujitsu-Rechner „besorgt“ und siehe da mit PXE-Boot ist linbo auf einmal da. Also liegt es wohl an den Dell-Rechnern oder dem BIOS. BIOS ist auf Legacy eingestellt (alternative UEFI) und Nic enabled mit PXE-Boot. Ist noch irgendetwas relevant im Bios oder gibt es unverträgliche Hardware?

Aber die Befehle funktionierten zuerst auch nicht, es kamen Fehlermeldungen, dass Dateien nicht geladen werden konnten. Die cloop-Dateien brauchen ein lmn- zu Beginn des Namens, genauso wie im Zip-File, leider hatte ich diese umbenannt wie sie in der readme-Datei zu sehen waren, wohl keine gute Idee gewesen. Aber dies war schnell entdeckt und behoben und der Fujitsu-PC läuft!

DELL-PCs
Processor : 3rd Gen Intel Core i7-3770 Processor (Quad Core, 3.40GHz Turbo, 8MB, w/ HD4000 Graphics)
Intel Core vPro Technology Enabled, Dell OptiPlex 9010
Grafikkarte : 1GB AMD Radeon HD 7470 (Halbe Höhe, 1DP und 1DVI-I)
Optical Drive : 8X Slimline DVD-ROM Drive
Hard Drive : 500GB 2.5 inch Serial ATA III Hybrid Hard Drive
Memory : 8GB (2X4GB) 1600 MHz DDR3 Non-ECC

Hallo Rolf,

Ich habe ein paar Dell Rechner (OptiPlex 9010) mit denen ich einen
Probe-Raum für das neue Netzwerk einrichten wollte. Habe mir nun noch
einen Fujitsu-Rechner „besorgt“ und siehe da mit PXE-Boot ist linbo auf
einmal da. Also liegt es wohl an den Dell-Rechnern oder dem BIOS. BIOS
ist auf Legacy eingestellt (alternative UEFI) und Nic enabled mit
PXE-Boot. Ist noch irgendetwas relevant im Bios oder gibt es
unverträgliche Hardware?

vorsicht: es muss bei den Clients PXE als erstes bootdevice eingetragen
sein, sonst geht ein remote wecken nciht.
Dabei auch darauf achten, dass der richtige PXE ganz oben steht: sind es
UEFI fähige Rechner muß folgender Eintrag ganz oben stehen:
PXE IPv4
und nicht
UEFI PXE IPv4
oder
PXE IPv6
oder
UEFI PXE IPv6

Aber die Befehle funktionierten zuerst auch nicht, es kamen
Fehlermeldungen, dass Dateien nicht geladen werden konnten. Die
cloop-Dateien brauchen ein lmn- zu Beginn des Namens, genauso wie im
Zip-File, leider hatte ich diese umbenannt wie sie in der readme-Datei
zu sehen waren, wohl keine gute Idee gewesen.

das geht schon, aber dann muß der Eintrag in der start.conf auch
angepaßt werden.

Beschreib mal den genauen bootverlauf bei den Dell die niciht funktioneiren.
Kannst du sie „von Hand“ direkt am Cleint erfolgreich in linbo booten
und dann partitionieren (im Imaging Reiter) und dann syncen?

LG

Holger

Hallo Holger u. a.,

vorab vielen Dank an Dominik und dich für den Client (lmn-bionic-1119), da ist ja schon jede Menge nützliche Arbeit erledigt worden :slight_smile:
Bei wine hat es bei mir Probleme gegeben: Beim Versuch wine mit Hilfe von lmlcc einzurichten, schlägt die eigentliche Installation von wine fehl, wobei es schon ein Verzeichnis ./wine gibt und auch das verlinkte Verzeichnis unter /home/linuxadmin ist vorhanden.
Ich habe dann mal versucht, wine ganz normal über die Konsole zu installieren, was aber mit verschiendenen Fehlermeldungen nicht klappte. Über das grafische Tool „Ubuntu Software“ wird ein „wine-development“ angeboten, was sich auch installieren lässt und mit dem man tatsächlich arbeiten kann. Nach der Installation kann man sogar vorhandene mit wine wohl früher installierte Programme wie z. B. ‚Crocodile Clips‘ öffnen, und auch neue installieren. Ich befürchte aber, dass dieser „Umweg“ im Mehrbenutzer-Modus nicht funktionieren wird. Hat jemand eine Idee?

Viele Grüße

Wilfried

Beschreib mal den genauen bootverlauf bei den Dell die niciht funktioneiren.
Kannst du sie „von Hand“ direkt am Cleint erfolgreich in linbo booten
und dann partitionieren (im Imaging Reiter) und dann syncen?

Wenn ich die Dell Rechner mittels F12 über Nic boote dann kommt

und weiter geht es nicht.

Hallo Rolf,

Wenn ich die Dell Rechner mittels F12 über Nic boote dann kommt

IMG_20200225_172900
https://ask.linuxmuster.net/uploads/default/original/2X/2/22bfc3c56703627a07d68979a629e3da17855032.jpeg

und weiter geht es nicht.

auf was genau steht den der Boot im BIOS?
Was steht den bei systemtype in der start.conf.?

LG

Holger

Hallo Rolf,

bitte poste auch mal die Zeilen für die DEL Clients aus der
/etc/linuxmuster/sophomorix/default-school/devices.csv

LG

Holger

Legacy
1.) Onboard Nic
2.) Festplatte

SystemType = bios64

R110;R110L05;bionic;b8:ca:3a:75:36:97;10.0.110.5;;;;staffcomputer;;1;;;;;
R110;R110L04;bionic;b8:ca:3a:96:5c:ea;10.0.110.4;;;;staffcomputer;;1;;;;;

Push!
Hat noch jemand eine Idee? Ich habe mal dem BIOS ein Update spediert, hat aber wie erwartet nichts gebracht. Eine weitere PC-Klasse machte auch keine Probleme und mittlerweile befürchte ich, dass es an der Firmware der Netzwerkkarte liegt.

Hallo Rolf,

Push!

sorry: hab zuviel um die Ohren :slight_smile:

Jetzt hab ich es mir noch mal angesehen: vor allem die specs deiner
Hardware, die du ja schon gepostet hattest:
DELL-PCs
Processor : 3rd Gen Intel Core i7-3770 Processor (Quad Core, 3.40GHz
Turbo, 8MB, w/ HD4000 Graphics)
Intel Core vPro Technology Enabled, Dell OptiPlex 9010
Grafikkarte : 1GB AMD Radeon HD 7470 (Halbe Höhe, 1DP und 1DVI-I)
Optical Drive : 8X Slimline DVD-ROM Drive
Hard Drive : 500GB 2.5 inch Serial ATA III Hybrid Hard Drive
Memory : 8GB (2X4GB) 1600 MHz DDR3 Non-ECC

AMD Grafikkarte … das wird es wohl sein.
Normalerweise sieht das aber anders aus, als bei dir: es geht nach dem
PXE schon weiter und man sieht dann textmodus bootendes linbo, das aber
dann da verhart und die Grafische Oberfläche erscheint nicht.
Das macht mich stutzig.

Ich hol mal aus:
Generell gibt es zwei unterschiedliche Hardwarearten, die beim booten
von linbo manchmal (oder immer) Problmee machen:
AMD Grafikkarten
Marvel Netzwerkkarten

Ich hab die Specs des Optoplex 9010 hier nachgeschaut:

Da ist eine INtel Netzwerkkarte drin.
Also wird es wohl die Grafikkarte sein.

Mach mal folgendes:

  1. in der start.conf. auf dem Server änderst du die Zeile:
    KernelOptions = quiet splash
    zu
    KernelOptions = quiet splash nomodeset

  2. linuxmuster-import-devices

  3. Client booten und schauen, ob es geht.

Ich habe in all den Jahren die wir linbo inzwischen haben erst eine
Hardware gesehen, bei der ich linbomäßig wirklich die Waffen strecken
mußte: terra „Tablets“ deren UEFI BIOS so dermaßen verhunst war, dass
linbo darauf nicht gebootet werden konnte.
Das gemeine war: eine Schule hatte ca. 16 von den Dingern im Einsatz.
Bald sind zwei kaput gegangen und wurden vom Hersteller getauscht:
angeblich gegen die gleiche Serie: war es aber nicht: komplett anders
Mainboard, BIOS und Prozessor: und das verhunste BIOS …
Terra kann ich nicht empfehlen…

LG

Holger

Hallo Holger,

zuerst einmal vielen Dank für deinen Support!

Leider war dies auch nicht die Lösung, es bleibt beim gleichen Bildschirm hängen. Habe in der start.conf auch mal die auskommentierte Zeile versucht, alle Versuche blieben beim gleichen alten Ergebnis.

Habe die Grafikkarte mal abgeschaltet und über das Mainboard (Integrated Intel® HD Graphics) den PC und Monitor über VGA verbunden. Habe die Grafikkarte sogar ausgebaut, leider jedes Mal mit dem gleichen Ergebnis.

Gruß
Rolf