Drucken über Coova

Hallo zusammen,

ich verzweifle an der Einrichtung der Möglichkeit von einem Coova-client zu drucken.
Ich bin nach der Anleitung im Wiki vorgegangen und habe in der Firewall eine Weiterleitung von blau nach grün direkt auf den Drucker erstellt.
Als root am Coova eingeloggt kann ich den Drucker anpingen. Von einem Coova-Client aus nicht.
In der Anleitung im Wiki stand, dass am Coova nix zu ändern sei, der würde alles durchlassen …
Habt ihr Tipps ?
Grüße Rainer

Hallo Rainer,

ich verzweifle an der Einrichtung der Möglichkeit von einem Coova-client
zu drucken.
Ich bin nach der Anleitung im Wiki vorgegangen und habe in der Firewall
eine Weiterleitung von blau nach grün direkt auf den Drucker erstellt.
Als root am Coova eingeloggt kann ich den Drucker anpingen. Von einem
Coova-Client aus nicht.
In der Anleitung im Wiki stand, dass am Coova nix zu ändern sei, der
würde alles durchlassen …
Habt ihr Tipps ?

die Weiterleitung im IPFire reicht nicht: du mußt in der access.conf
unter /etc/cups/ auch den IP Bereich des WLANs als "erlaubte Subnetze"
deklarieren: sonst druckt der nciht.
Mit welcher IP er dort ankommt, weiß ich aber nicht.
Die des IPFire?
Die des Coova? oder die des WLAN Cliennts: das mußt du ausprobieren.

LG

Holger

Hallo Rainer, hallo Holger,

die Printjobs kommen von der dem IPFire zugewandten IP des Coova. Es kommen sogar die Usernamen beim Cups an.

Bei uns funktioniert das problemlos mit Linux- und Mac-Rechnern. Unter Windows haben wir seit einiger Zeit massive Probleme, Windows hängt sich beim Zugriff auf die Drucker mehr oder weniger auf. Früher ging das mal.

Viele Grüße

Jörg

Hallo Jörg,

welchen Treiber nutzt Ihr in Windows. Wir benutzen diesen generischen.

Gruß Jürgen

Hallo Jörg,

die Printjobs kommen von der dem IPFire zugewandten IP des Coova. Es
kommen sogar die Usernamen beim Cups an.

Bei uns funktioniert das problemlos mit Linux- und Mac-Rechnern. Unter
Windows haben wir seit einiger Zeit massive Probleme, Windows hängt sich
beim Zugriff auf die Drucker mehr oder weniger auf. Früher ging das mal.

sind das neuere Windows Versionen? (8 und 10)
Windows zieht seit 8 vor dem Drucken ein riesen Geschnatter mit dem
Drucker ab: das geht gerne mal schief.
Es gibt aber einen Reghack der Windwos wieder zu normalen Umgangsformen
zurechtstutzt: das müßte dann aber duckduckgo beantworten.

LG

Holger

Hallo Holger

Hallo Rainer,

da kam nciht mehr als “Hallo Holger” an.
Ich nehme an, dass du Trenner in deinen Beitrag eingefügt hattest wie


nur mehr davon: dann denkt unser Forum, dass da eine Signatur käme und schneidet ab …

LG

Holger

[baumhof] baumhof https://ask.linuxmuster.net/u/baumhof Vize-Präsident
29. April

Hallo Rainer,

da kam nciht mehr als “Hallo Holger” an.

ok, dann hier der Rest:

Ist will im ersten Schritt gar nicht über Cups drucken
sondern direkt auf die IP des Druckers im grünen Netz.

Wie gesagt: vom Coova als ROOT kann ich an der Komandozeile alle
gewünschten IPs im grünen Netz anpingen aber eben nicht von einem
Coova-Client … da ist irgendwie/wo eine Blockade …

Grüße Rainer

p.s. wäre es eine Idee auf dem chilli-Server einen Cups zu installieren,
der mit dem des Servers kommunizieren darf?

Hallo Rainer,

cups auf coova zu installieren, wäre natürlich eine Idee.

Es sollte jedoch auch möglich sein, ipfire so zu konfigurieren, dass er
Druckaufträge von BLAU(?) nach GRUEN erlaubt.
Bei mir (WLAN mit RADIUS in BLAU, kein coova) sehen die freigegebenen
Ports von BLAU nach GRUEN so aus.
Damit ist es sowohl möglich, ohne Kennwort Druckaufträge an cups auf
server als auch an die Printserver direkt zu senden. Auch kann man sich
die Shares mit smbmount verbinden.

Regel Nr. 5 ist vielleicht etwas “großzügig”. Mir geht es jedoch mehr
darum, die privaten WLAN-Clients der KollegInnen vor Angriffen aus GRUEN
zu schützen (z. B. smbmount ungeschützer Windowsfreigaben) als umgekehrt
die Schulrechner vor Angriffen von privaten WLAN-Clients aus.

Gruß Jürgen

ipfire-Firewallregeln-radius-blau.pdf (208 KB)

Hallo!

Ich würde nicht über CUPS drucken. Windows-Kollegen blockierten bei mir des öfteren die Warteschlangen mit falschen Druckertreibern. Seitdem lasse ich nur noch direkt-Druck zu. Hast Du alle Ports für die Drucker-IP offen?

LG
Max

Hi.
Ich hänge mich mal kurz an diesen alten Artikel dran … bei uns ist das Problem auch wieder aufgetaucht: ein Kollege möchte aus dem Schul-WLAN hinter dem coova drucken. Der Auftrag kommt aber nie an. Ich habe die Ports ebenfalls entsprechend Anleitung freigegeben. Als Drucker habe ich jedoch einen neuen TCP/IP-Port unter Windows eingerichtet, der dann als Jet Direct auf die URL des CUPS-Servers zeigt:
http://10.16.1.1:631/printers/Lehrerzimmer . Als Druckertreiber ist dann natürlich der richtige Treiber eingerichtet. Dennoch kommen die Aufträge nicht an. Eine aktuelle Logdatei habe ich im Moment leider nicht.

Die zweite Frage dazu: Wenn ich manuell etwas in der access.conf von CUPS ändere und danach ein import_workstations laufen lasse, ist es wieder weg, oder??

Schöne Grüeß und gutes Gelingen in Bonn!
Michael

Hallo,

das Problem ist (so war es bei uns), dass der Auftrag durch zwei Filter / Treiber geht, einmal auf dem Client und einmal auf dem Server.

Siehe auch:

Warning: Avoid configuring both the server and the client with a printer filter - either the print queue on the client or the server should be ‘raw’. This avoids sending a print job through the filters for a printer twice, which can cause problems (for instance, [2]). See #Usage for an example of setting a print queue to ‘raw’.

Also muss der Treiber auf einer Seite auf “raw” gesetzt sein. Dann geht es wieder.

Im Allgemeinen scheint das aber hier kein Problem zu sein, oder? Wie habt ihr eure Drucker konfiguriert (Treibermäßig) beim Drucken aus dem WLAN? Habt ihr auf dem Client und dem Server jeweils den gleichen Treiber? Oder ist eine Seite “generic”?

vG Stephan

Hallo,
Es gibt eine Cup Access_custom.conf (oder so ähnlich) Datei, die beim Import_Workstations nicht angetastet wird und die dann immer in die normale Access-Datei eingebunden wird.
Ich habe die Erwartungen dort eingetragen.
Viele Grüße
Manuel

Die Datei gibt’s hier leider nicht – daher weiß ich nciht, wie die aufgebaut sein muss.

14:05/0 server /etc/cups # ll
insgesamt 96
-rw-r--r-- 1 root root 2020 Nov 23 09:28 access.conf
-rw-r--r-- 1 root root 1947 Mai  5  2017 access.conf.bak
-rw------- 1 root lp    108 Jun 21  2013 classes.conf
-rw-r----- 1 root lp   2209 Sep  6  2017 cupsd.conf
-rw-r----- 1 root root 2443 Nov  4  2015 cupsd.conf.backup
-rw-r--r-- 1 root root 4737 Mai 13  2013 cupsd.conf.default
-rw-r----- 1 root root 2495 Sep  6  2016 cupsd.conf.dpkg-bak
-rw-r--r-- 1 root root 2495 Dez 16  2013 cupsd.conf.O
-rw-r--r-- 1 root root 3079 Mär 19  2013 cups-files.conf
-rw-r--r-- 1 root root 9511 Apr  3  2012 cups-pdf.conf
drwxr-xr-x 2 root lp   4096 Okt 22 05:20 ppd
-rw------- 1 root lp   6469 Nov 24 07:49 printers.conf
-rw------- 1 root lp   6469 Nov 23 12:16 printers.conf.O
-rw-r--r-- 1 root root  240 Jun 21  2013 raw.convs
-rw-r--r-- 1 root root  211 Jun 21  2013 raw.types
-rw-r--r-- 1 root root  160 Mai 13  2013 snmp.conf
drwx------ 2 root lp   4096 Jun 21  2013 ssl
-rw-r----- 1 root lp     93 Nov 24 11:20 subscriptions.conf
-rw-r----- 1 root lp    241 Nov 24 11:19 subscriptions.conf.O

Ich meine, dass der Drucker auf RAW steht und über Port 9100 drucken will. In der access.conf steht auch bereits das Netzwerk für den Coova mit drin. Ich bin auch sicher, dass da schon mal irgendwann ging … (allerdings war das glaube ich noch zu Zeiten ohne Subnetting/VLAN, wenn mich nicht alles täuscht?)

Schöne Grüße,
Michael

Hallo Michael,

die Datei heißt “access_custom.conf”.

Die letzte Zeile der access.conf lautet bei mir:
include /etc/cups/access_custom.conf
(hier wird also die Datei eingebunden).

Die access_custom.conf sieht dann so aus:

<Location /printers/H0.04-Farblaser-Physik>
  Allow From 172.16.*.* 
</Location>
<Location /printers/C0.02-Farblaser-Chemie>
  Allow From 172.16.*.* 
</Location>
<Location /printers/H0.13-swLaser-Erdkunde>
  Allow From 172.16.*.* 
</Location>

viele Grüße
Manuel