DNS-Auflösung über OPNsense fehlgeschlagen (linuxmuster.net Client-Installation)

Hallo Support-Team,

auf meinem Musterd-Client (Linux PC, IP: 10.0.1.1) wollte ich den Schritt „Paket linuxmuster-linuxclient7 installieren“ nach folgender Anleitung ausführen:

latest » Muster-Client aufsetzen » Betriebssysteme installieren » Linux-Client

konnte nicht ausgeführt werden, da die DNS-Auflösung nicht funktioniert.

Das Problem betrifft auch den Admin-PC (IP: 10.0.0.10) sowie den linuxmuster-Server selbst. Nach einer Recherche liegt die Ursache wahrscheinlich bei den OPNsense-Einrichtungen.

Tests bei Linuxmuster:

Plaintext

linuxadmin@server:~$ sudo -i
[sudo] password for linuxadmin:
root@server:~# ping -c 3 10.0.0.254
PING 10.0.0.254 (10.0.0.254) 56(84) bytes of data.
64 bytes from 10.0.0.254: icmp_seq=1 ttl=64 time=0.238 ms
64 bytes from 10.0.0.254: icmp_seq=2 ttl=64 time=0.323 ms
64 bytes from 10.0.0.254: icmp_seq=3 ttl=64 time=0.364 ms

--- 10.0.0.254 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2038ms
rtt min/avg/max/mdev = 0.238/0.308/0.364/0.052 ms
root@server:~# ^C
root@server:~# ping -c 3 1.1.1.1
PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
64 bytes from 1.1.1.1: icmp_seq=1 ttl=56 time=11.4 ms
64 bytes from 1.1.1.1: icmp_seq=2 ttl=56 time=11.3 ms
64 bytes from 1.1.1.1: icmp_seq=3 ttl=56 time=11.2 ms

--- 1.1.1.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2004ms
rtt min/avg/max/mdev = 11.185/11.299/11.424/0.097 ms
root@server:~# dig @10.0.0.254 google.de
;; communications error to 10.0.0.254#53: timed out
;; communications error to 10.0.0.254#53: timed out
;; communications error to 10.0.0.254#53: timed out

; <<>> DiG 9.18.39-0ubuntu0.24.04.5-Ubuntu <<>> @10.0.0.254 google.de
; (1 server found)
;; global options: +cmd
;; no servers could be reached
root@server:~# dig @1.1.1.1 google.de

; <<>> DiG 9.18.39-0ubuntu0.24.04.5-Ubuntu <<>> @1.1.1.1 google.de
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23222
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;google.de.                 IN      A

;; ANSWER SECTION:
google.de.              69      IN      A       142.251.110.94

;; Query time: 9 msec
;; SERVER: 1.1.1.1#53(1.1.1.1) (UDP)
;; WHEN: Wed Aug 19 20:42:02 CEST 2026
;; MSG SIZE  rcvd: 54

root@server:~# 

Tests bei OPNsense:

*** firewall.linuxmuster.lan: OPNsense 25.7.11_9 (amd64) ***

LAN (vtnet1) → v4: 10.0.0.254/16
WAN (vtnet0) → v4/DHCP4: 192.168.178.89/24

Könnten Sie bitte auch das Bild im Anhang überprüfen?

Sollte ich etwas bei den OPNsense-Einstellungen anpassen?

Viele Grüße

Emteiaz Krate

Hallo Support,

könnt ihr mir bitte helfen oder einen Tipp geben, woran dieses Problem liegen könnte?

Viele Grüße
Emteiaz Krate

Hallo Emteiaz!

Der Haken bei Use System Nameservers muss weg. Ist das nicht so dokumentiert?

VG, Thomas

Hallo Thomas,

danke für die Antwort.

Der Haken bei Use System Nameservers muss weg. Ist das nicht so dokumentiert? : Leider Nein, hiermit schicke ich dir ein Bild davon:

ich habe OPNsense installiert und konfiguriert nur erst bei der Installation nach der Dokumentation: https://docs.linuxmuster.net/de/latest/installation/install-from-scratch/basis_opnsense.html und dann nach der Server Installation habe ich in OPNsense auch System → Einstellungen → Allgemein und Dienste → Unbound DNS → Query Forwarding nach diesem Link : https://docs.linuxmuster.net/de/latest/setup/setup-gui.html manuell konfiguriert.

Viele Grüße

Emeiaz Krate

Das scheint mir nicht mehr aktuell zu sein. So funktionierts:

VG, Thomas