ComputerName wird nicht übernommen


#1

Hallo!

Im Linbo-Startschirm wird der Computername richtig angezeigt.
Startet man dann das Windows-Image, so erhält der Client nicht den von Linbo angezeigten Computernamen sondern den vom PC, von dem aus das Image erstellt wurde.

Die reg-Datei liegt vor.

Wird sie vielleicht nicht verarbeitet?

Gruß
Gerhard


#2

Hallo Gerhard,

Im Linbo-Startschirm wird der Computername richtig angezeigt.
Startet man dann das Windows-Image, so erhält der Client nicht den von
Linbo angezeigten Computernamen sondern den vom PC, von dem aus das
Image erstellt wurde.

Die reg-Datei liegt vor.

Wird sie vielleicht nicht verarbeitet?

offensichtlich nicht :slight_smile:

Um was für ein Betriebsystem handelt es sich den?
Wo ist der regpatch den her?
Welche Rechte hat er?

Bei mir:
ls -al /var/linbo/semwin10-800.cloop*
-rw-rw-r-- 1 root root 11925252133 Jan 4 2018
/var/linbo/semwin10-800.cloop
-rw-rw-r-- 1 root root 1129 Jan 4 2018
/var/linbo/semwin10-800.cloop.desc
-rw-rw-r-- 1 root root 144 Jan 4 2018
/var/linbo/semwin10-800.cloop.info
-rw------- 1 root root 154 Jan 4 2018
/var/linbo/semwin10-800.cloop.macct
-rw-rw-r-- 1 root root 856 Jan 7 2016
/var/linbo/semwin10-800.cloop.reg
-rw-rw-r-- 1 root root 910049 Jan 4 2018
/var/linbo/semwin10-800.cloop.torrent

Also 644

Könntest du uns noch die Zeile des CLeints aus der
/etc/linuxmuster/workstations schicken?

LG

Holger


#3

Hallo Holger,
sind die Rechte nicht 664 (rw-rw-r)?
Gruß Roland


#4

Hallo Gerhard,

ich hatte das gleich Problem. Bei mir war der Cache der Clients voll.
Schau mal hier:

Viele Grüße
Dominik


#5

Hallo Roland,

-rw-rw-r-- /var/linbo/semwin10-800.cloop.reg

sind die Rechte nicht 664 (rw-rw-r)?

tja: da komm ich wohl nicht raus, du hast offensichtlich recht :slight_smile:

Danke fürs richtig stellen.

LG

Holger


#6

Hallo Holger,

bei mir sieht es im Dateisystem so aus:
12:58/2 server /var/linbo # ll win10fs.cloop*
-rw-rw-r-- 1 root root 9565118474 Apr 16 13:54 win10fs.cloop
-rw-rw-r-- 1 root root 12 Apr 16 13:47 win10fs.cloop.desc
-rw-rw-r-- 1 root root 133 Apr 16 13:54 win10fs.cloop.info
-rw-rw-r-- 1 root root 413 Mai 17 13:09 win10fs.cloop.postsync
-rw-rw-r-- 1 root root 671 Feb 22 2018 win10fs.cloop.reg
-rw-rw-r-- 1 root root 729983 Apr 16 13:55 win10fs.cloop.torrent

Die Rechte stimmen mit 654. Im Vergleich zu Deiner Ausgabe fehlt eine cloop.macct-Datei. Wird diese gebraucht?

Die Zeile aus der workstations-Datei ist:
r305;305pc26;win10fs;90:1B:0E:DC:83:CF;10.18.5.26;;1;1;1;1;1;

Es handelt sichum Widnows 10.

Die reg-datei hat den Inhalt

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ComputerName\ActiveComputerName]
“ComputerName”="{$HostName$}"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ComputerName\ComputerName]
“ComputerName”="{$HostName$}"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\services\Tcpip\Parameters]
“Hostname”="{$HostName$}"
“NV Hostname”="{$HostName$}"

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System]
“DefaultLogonDomain”=“SCHULE”

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters]
“Domain”=“SCHULE”
“NV Hostname”="{$HostName$}"
“Hostname”="{$HostName$}"
“NV Domain”=“SCHULE”

Gruß
Gerhard


#7

Das Problem ist behoben.

Folgendes wurde vor Ort gemacht:

win10.image.reg war mit einem Linux-Editor bearbeitet. DIe .reg-Datei wurde berichtigt und in den Linbo-Ordner mit dem richtigen Namen kopiert.

Danach wurde der Besitzer (root:root) und die Rechte (644) gesetzt.

In der start.conf war ein differentielles Image eingetragen welches nicht existierte. Die entsprechende Zeile wurde in

Image =

abgeändert.

Sicherheitshalber wurden auch noch Labels eingetragen.

Nach all den Änderungen funktionierte das Übetragen des Rechnernamens.

Was derzeit noch nicht funktioniert.

Linbo loggt nicht bzw. die Log-Dateien sind leer.

@Holger und Thorsten vielen Dank für Eure Unterstützung

Gruß

Alois