Client von Testserver auf Produktivserver migrieren (v7): Anmeldeproblem (und Lösung)

Damit es für alle dokumentiert ist: Hatte das Problem, das sich Domänennutzer (z.B. global-admin) nach verschieben des Clients auf den neuen Server nicht mehr grafisch anmelden konnten.

Lösung war in /home/cache die bestehenden Benutzerverzeichnisse zu löschen; angemeldet als linuxadmin per sudo.

Hintergrund: Der Client war in die Domäne des Testservers eingebunden. Anschliessend wurde der Client in die Domäne des Produktivservers eingebunden (mit linuxmuster-cloop-turnkey). Als Folge befanden sich in /home/cache Benutzerverzeichnisse mit falschen User- und Gruppen-IDs.

Wie ich gelernt habe, hätte ich besser angemeldet als linuxadmin die Nutzerverzeichnisse in /home/cache vor der Migration gelöscht. (Noch komfortabler wäre, wenn linuxmuster-cloop-turnkey das automatisch machen würde.)

Um den Client zu migrieren (linux mint 2020 image von v7), habe ich das Basisimage auf dem Server installiert (gemäss wiki) und den Client per Webinterface aufgenommen. Anschliessend habe ich den Client unsynchronisiert (!) gestartet, dann via user linuxadmin in die Domäne aufgenommen. Zuletzt per linbo ein Image erstellt und hochgeladen. - Bin linuxmuster-Neuling. Vielleicht soll man das ja auch ganz anders machen?

Quellen: hier und hier

1 Like

Danke spblinux für die Rückmeldung! Um das als Lösung markieren zu können (dieser Post) und als Anerkennung für die Meldung ein :heart: von mir.

Beste Grüße

Thorsten