Bug auf der Schulkonsole - Schuleinstellungen?

Hallo zusammen,

auf der Schulkonsole habe ich unter Schuleinstellungen eine Mail-Domaine für die Rolle „teachers“ eingetragen. Das hat er akzepiert und gespeichert.
Danach bekomme jedoch ich eine Fehlermeldung wenn ich in die Schuleinstellungen bzw. die Extraquotas gehen will :

Traceback (most recent call last): File "/usr/local/lib/python3.6/dist-packages/aj/api/endpoint.py", line 74, in wrapper result = fx(self, context, *args, **kwargs) File "/usr/lib/linuxmuster-webui/plugins/lmn_settings/views.py", line 63, in handle_api_settings config.read(path) File "/usr/lib/python3.6/configparser.py", line 697, in read self._read(fp, filename) File "/usr/lib/python3.6/configparser.py", line 1092, in _read fpname, lineno) configparser.DuplicateOptionError: While reading from '/etc/linuxmuster/sophomorix/default-school/school.conf' [line 23]: option 'mail_local_part_map' in section 'role.teacher' already exists

Eine Kontrolle der Config-Datei school.conf ergab folgenden Fehler:

[role.teacher]
        QUOTA_DEFAULT_GLOBAL=2006
        QUOTA_DEFAULT_SCHOOL=2506
        CLOUDQUOTA_PERCENTAGE=100
        MAILQUOTA_DEFAULT=306
        WEBUI_PERMISSIONS=
wbs-wissen.de   wbs-wissen.deMwbs-wissen.deAwbs-wissen.deIwbs-wissen.deLwbs-wissen.deDwbs-wissen.deOwbs-wissen.deMwbs-wissen.deAwbs-wissen.deIwbs-wissen.deNwbs-wissen.de=wbs-wissen.d$

MAIL_LOCAL_PART_MAP=w
MAIL_LOCAL_PART_MAP=b
MAIL_LOCAL_PART_MAP=s
MAIL_LOCAL_PART_MAP=-
MAIL_LOCAL_PART_MAP=w
MAIL_LOCAL_PART_MAP=i
MAIL_LOCAL_PART_MAP=s
MAIL_LOCAL_PART_MAP=s
MAIL_LOCAL_PART_MAP=e
MAIL_LOCAL_PART_MAP=n
MAIL_LOCAL_PART_MAP=.
MAIL_LOCAL_PART_MAP=d
MAIL_LOCAL_PART_MAP=e
MAIL_LOCAL_PART_MAP=
MAIL_LOCAL_PART_MAP=M
MAIL_LOCAL_PART_MAP=A
MAIL_LOCAL_PART_MAP=I
MAIL_LOCAL_PART_MAP=L
MAIL_LOCAL_PART_MAP=_
MAIL_LOCAL_PART_MAP=L
MAIL_LOCAL_PART_MAP=O
MAIL_LOCAL_PART_MAP=C
MAIL_LOCAL_PART_MAP=A
MAIL_LOCAL_PART_MAP=L
MAIL_LOCAL_PART_MAP=_
MAIL_LOCAL_PART_MAP=P
MAIL_LOCAL_PART_MAP=A
MAIL_LOCAL_PART_MAP=R
MAIL_LOCAL_PART_MAP=T
MAIL_LOCAL_PART_MAP=_
MAIL_LOCAL_PART_MAP=S
MAIL_LOCAL_PART_MAP=C
MAIL_LOCAL_PART_MAP=H
MAIL_LOCAL_PART_MAP=E
MAIL_LOCAL_PART_MAP=M
MAIL_LOCAL_PART_MAP=E
MAIL_LOCAL_PART_MAP==
MAIL_LOCAL_PART_MAP=

MAIL_LOCAL_PART_MAP=    MAIL_LOCAL_PART_MAP=

wbs-wissen.de ist unsere Maildomäne, die ich auf der Schulkonsole EINMALIG eingetragen hatte.
Sie taucht aber nun ein bissel oft in der Config-Datei auf :slight_smile: BUG??

Nach Bereinigung der Datei (löschen der ganzen wbs-wissen.de & der MAIL_LOCAL_PART_MAP=*) klappt der Zugang zu den genannten Bereichen der Schulkosole wieder…

LG
Ralf

Hallo Ralf,

Danke, das ist schon korrigiert, kommt in der nächste Version.

Gruß

Arnaud

1 Like

Hallo Arnaud,

danke für die Info!

Viele Grüße
Ralf