Bildschirmauflösung config Datei?


#1

Hallo,

wir haben in manchen Räumen alte Beamer, die nicht die Bildschirmauflösung des erkannten Monitors am Lehrer-PC darstellen können.
Daher müssen wir bisher an diesen PCs rechts oben auf “das Zahnrad” / Systemeinstellungen… / Anzeigegeräte und
dort auf die Auswahl “Auflösung”. Dort stellen wir dann auf 1024x768 um.
Dann zeigen sowohl der Monitor als auch der Beamer, der an einer VGA-Weiche Hängt, das Bildschirmsignal an.

Nun würde ich gerne wissen wo ich diese Einstellungen im System finde. Schön wäre es, wenn diese Einstellung in nur einer Datei zu finden wäre.
Dann könnte ich diese Datei den entsprechenden Clients per Postsync zukommen lassen.

Viele Grüße
Matthias


#2

Hallo Matthias,

wir haben in manchen Räumen alte Beamer, die nicht die
Bildschirmauflösung des erkannten Monitors am Lehrer-PC darstellen können.
Daher müssen wir bisher an diesen PCs rechts oben auf “das Zahnrad” /
Systemeinstellungen… / Anzeigegeräte und
dort auf die Auswahl “Auflösung”. Dort stellen wir dann auf 1024x768 um.
Dann zeigen sowohl der Monitor als auch der Beamer, der an einer
VGA-Weiche Hängt, das Bildschirmsignal an.

Nun würde ich gerne wissen wo ich diese Einstellungen im System finde.
Schön wäre es, wenn diese Einstellung in nur einer Datei zu finden wäre.
Dann könnte ich diese Datei den entsprechenden Clients per Postsync
zukommen lassen.

du mußt eien /etc/X11/xorg.conf anlegen und korrekt befüllen.

… aber ich würde das anders machen: nimm die Buttonbar und erschaffe
damit eine Buttonbar auf dem Desktop und nenn den Knopf für 1024x768
geklont einfach “Beamer”

Buttonbar geht auch per postsync.

Such mal danach im wiki

LG

Holger


#3

Hallo Holger,

habe das mit der Buttonbar nicht gleich auf Anhieb verstanden, aber dann noch diese Hinweise gefunden und dann so auch gelöst.

Vielen Dank
LG Matthias


#4

Hallo Holger,

wir haben offensichtlich noch ein weiteres Problem mit der Bildschirmauflösung.

Daher muss ich wohl doch mein xenial dazu bringen, dass es standardmässig mit der Auflösung 1024x768 startet.
Denn wir haben bei diesen PCs hinten den DVI Out am Monitor und an dem VGA Out ältere Beamer über eine Dokukam geschleift angeschlossen. Die Beamer können 1024x768.

Mit dem Ergebnis, dass man auf den Beamern den Start bis kurz vor erscheinen des Anmeldebildschirms alles mit verfolgen kann, danach zeigt der Beamer aber nichts mehr an.
Seltsamerweise auch nicht, wenn man nach erfolgreicher Anmeldung in Ubuntu die Auflösung auf 1024x768 einstellt. Sonst hätte hier auch die Bottonbar-Lösung geholfen.

Du hast mal angedeutet, dass man das mit einer …xorg.conf Datei bewerkstelligen kann.

Leider finde ich bei mir auf den Clients keine solche Datei.
Oder kann man dem System noch auf andere Weise sagen, dass es unter 1024x768 starten soll.

PS: In der Grafischen Oberfläche findet man unter Anzeigegeräte nur einen Monitor u. kann auch keinen weiteren hinzufügen oder erkennen lassen.
Habe irgendwie das gefühl, dass das Betriebssystem den VGA Out ausschaltet.

Viele Grüße
Matthias


#5

Hallo Michael,

Daher muss ich wohl doch mein xenial dazu bringen, dass es
standardmässig mit der Auflösung 1024x768 startet.
Denn wir haben bei diesen PCs hinten den DVI Out am Monitor und an dem
VGA Out ältere Beamer über eine Dokukam geschleift angeschlossen. Die
Beamer können 1024x768.

Mit dem Ergebnis, dass man auf den Beamern den Start bis kurz vor
erscheinen des Anmeldebildschirms alles mit verfolgen kann, danach zeigt
der Beamer aber nichts mehr an.
Seltsamerweise auch nicht, wenn man nach erfolgreicher Anmeldung in
Ubuntu die Auflösung auf 1024x768 einstellt. Sonst hätte hier auch die
Bottonbar-Lösung geholfen.

Du hast mal angedeutet, dass man das mit einer …xorg.conf Datei
bewerkstelligen kann.

baumhof:

/etc/X11/xorg.conf anlegen und korrekt befüllen

Leider finde ich bei mir auf den Clients keine solche Datei.
Oder kann man dem System noch auf andere Weise sagen, dass es unter
1024x768 starten soll.

normalerweise ist keine xorg.conf da: dann wird das alles vom
Betriebsystem direkt gesteuert: legst du eine an, wird diese befolgt.

Wie man die richtig schreibt, mußt du duckduckgo befragen.

PS: In der Grafischen Oberfläche findet man unter Anzeigegeräte nur
einen Monitor u. kann auch keinen weiteren hinzufügen oder erkennen lassen.
Habe irgendwie das gefühl, dass das Betriebssystem den VGA Out ausschaltet.

ich würde dir empfehlen das ganze erstmal mit xrandr zu analysieren: da
findest du raus, ob der VGA “gefunden” wird.
Mit xrandr scripten (die du auch hinter die Buttonbar legen kannst)
kannst du dann auch sowas wie: VGA 1024 Auflösung und DVI 1280 Auflösung
realisieren.

LG

Holger


#6

Hallo Matthias,

bei ganz problematischen Fällen habe ich die Kombination Rechner und Beamer richtig eingestellt und dann diese Einstellung mit ins Image genommen. Ubuntu “merkt” sich diesen Sonderfall und reagiert beim nächsten Mal mit den gewünschten Einstellungen für diesen Fall, der Rest wird wie früher bedient. Ein wenig umständlich, weil man evtl. auf postsync achten muss.

Viele Grüße

Wilfried


#7

Hallo Wilfried,

genau das würde ich gerne machen - direkt im Image als linuxadmin…
bekomme ich das leider noch nicht hin.

Stelle ich über die Systemeinstellungen die Auflösung um, ist sie nach reboot unsyncronisiert und selbst auch nach einem Ab- und Anmelden wieder futsch.

Das meinte wohl Holger auch mit “das macht das Betriebssytem automatisch”

(Das postsync kommt mir beim unsyncronisierten Start noch nicht in die Quere)

Jetzt muss ich nur noch zum xrandr X11 xorg.conf Spezialisten werden :stuck_out_tongue:
Mal schaun… ob ich das hin bekomme…

Viele Grüße
Matthias


#8

Hallo zusammen,

leider gelingt mir die generelle Einstellung der Bildschirmauflösung nicht. Mit xrandr scheint es nur nach dem Anmeldefenster zu funktionieren, wenn man ein script in den Autostart bringt.

Generell sollte es wohl mit xorg.conf … gehen.
Nur wie komme ich zu so einer Konfiguration, wenn ich xorg.conf auf meinem System gar nicht finde?
Vermutlich genügt es nicht lediglich eine passende xorg.conf Datei im X11 Ordner… zu haben.

Viele Grüße
Matthias


#9

Hallo Matthias,

Generell sollte es wohl mit xorg.conf … gehen.
Nur wie komme ich zu so einer Konfiguration, wenn ich xorg.conf auf
meinem System gar nicht finde?
Vermutlich genügt es nicht lediglich eine passende xorg.conf Datei im
X11 Ordner… zu haben.

ja.
Erstellen kannst du sie nach VOrlagen im Netz.

Früher ging das auch mal so:
einmal Knoppix auf dem Client booten und dann die dort vorhandene
xorg.conf nehmen.
Aber neuere knoppix erschaffen die vielleicht auch nicht mehr …

Frag mal duckduckgo nach xorg.conf erstellen.

LG

Holger


#10

Hallo Holger,
vielen Dank.
Grüße Matthias


#11

Also ich mache das seit Jahren für Ubuntu 14.04 per postsync für ein ähnliches Problem. Ich kopiere einfach nach der raumspezifischen Anpassung der Bildschirmeinstellungen die Datei ~/.config/monitors.xml ins postsync-Verzeichnis …/common/linuxadmin/.config/monitors.xml und nach…/common/var/lib/lightdm/.config/xml dann wird in jedem Raum mit identischer Hardware die gewünschte Sondereinstellung sowohl für den Standardnutzer als auch für den Login-Bildschirm (/lightdm/…) aktiviert. Beim nächsten Image ist es dann sowieso drin. Ihr werdet das dann halt raumspezifisch syncen müssen, da das mit der Weiche doch noch eine andere Sache ist, aber ich glaube dann sollte es gehen

Viel Erfolg

Helmuth


#12

Hallo Helmuth,

das mach ich mit den Monitoreinstellungen auch so, gibt es das auch für Client-spezifische Soundeinstellungen? D.h. Weißt du welche Datei(en) für die Soundeinstellungen zuständig sind?
Wir benutzen auf unseren Xenialclients 3 verschiedene Varianten: HDMI, Displayport, Analog
Wenn ich standardmäßig auf HDMI stelle haben die PC’s ohne HDMI-Ausgang kein Problem, sie stellen automatisch um. Die PC’s die den Ton über Displayport ausgeben funktioieren aber nur wenn man vorher noch einmal auf Analoge Ausgabe stellt und dann erneut auf HDMI/Displayport wechselt.

Grüße Dieter


#13

Hallo Dieter

Wir verlassen jetzt zwar die Bildschirmauflösung aber trotzdem. Ja, nach einigen Tagen Suche habe ich den einzigen Raum in dem der Ton über HDMI ausgegeben werden soll, so gesynct:

  • Als linuxadmin die gewünschte Ausgabe wählen

  • Die Datei /home/linuxadmin/.config/pulse/…-default.sink ins entsprechende,raumspezifische linuxmuster-client-Verzeichnis auf dem Server kopieren

  • Dafür sorgen, dass pulsaudio auch neu startet mit einer Datei im Verzeichnis /home/linuxadmin/.config/autostart/pulseaudio.desktop mit Inhalt

[Desktop Entry]
Type=Application
Exec=pulseaudio -k
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[de_DE]=Ton
Name=Ton
Comment[de_DE]=Ton beim Login zurücksetzen
Comment=

Funktioniert seit über zwei Jahren

Viel Erfolg

Helmuth


#14

Hallo, bin leider erst jetzt dazu gekommen dein Tipp umzusetzen.
Hier wird ganz gut beschrieben, wie man sich eine xorg.conf erstellen kann:

Leider funktioniert bei mir das Beenden des X-Servers mit dem Befehl:
/etc/init.d/gdm stop
nicht, da ich im xenial an diesem Ort kein gdm finde.
Gibt es noch eine andere Möglichkeit den X-Server zu beenden?

Viele Grüße
Matthias Lauffer


#15

ich nehme immer

/etc/init.d/lightdm restart

wenn sich mal ein Desktop eines Schüler aufgehängt hat …
(Ubuntu 16.04 hier aus der Liste).

Schöne Grüße,
Michael


#16

Hallo Michael,

danke, hatte gerade
/etc/init.d/lightdm stop
versucht.

Der X-Server scheint down zu sein, jedenfalls bekommt man mit STRG+ALT+F7 nur noch einen schwarzen Bildschirm.
So weit so gut.

Nun soll ich mit:
X -configure
eine Datei xorg.conf erzeugen.

leider bekomme ich dann eine Meldung:

No devices to configure. Configuration failed.
(EE) Server terminated with error (2). Closing log file.

PS:
Leider hilft auch diese Seite
https://wiki.ubuntuusers.de/xorg.conf.d/
mir nicht weiter.
Im angegebenen Ordner befinden sich zwar Files, nur welche, wie angepasst werden soll ? hm?

VG
Matthias