BBB Update auf 2.2.10 nginx bockt rum und will nicht mehr starten

Hab vorhin das Update von BBB auf 2.2.10 gemacht und seitdem bockt nginx rum, falscher Name in der Config, proxy_pass auf https geht so nicht usw. usf.

Hat das jemand schon ohne Probleme durchgezogen? Dachte ich haette da eine weitgehend unverbastelte Standardkonfiguration.

Gruss Harry

Hallo Harry,

mach mal einen Serverneustart und schau, ob dann alles wieder geht…

LG

Holger

Holger, also bitte. :grinning:
Irgendeine Komponente (von nginx oder von BBB) ist jetzt empfindlicher gegen Fehler in Konfigdateien - vermute ich.

So sieht das dann bei bbb-conf --check aus

Warning: You have this server defined for https, but in
#
#   /etc/bigbluebutton/nginx/sip.nginx
#
#  did not find the use of https in definition for proxy_pass
#
#            proxy_pass http://213.239.209.42:5066;
#

# Warning: You have this server defined for https, but in
#
#   /etc/bigbluebutton/nginx/sip.nginx
#
#  did not find the use of port 7443 in definition for proxy_pass
#
#            proxy_pass http://213.239.209.42:5066;

… OK: hast du also schon gemacht … Versuch war es Wert :slight_smile:

Dann wĂĽrde ich nochmal:
bbb-conf --setip

machen und wenn das auch nicht hiflt, kontrollieren, ob die Einstellungen stimmen die man hier zum umstellen auf https machen muss:

https://docs.bigbluebutton.org/2.2/install.html#configure-ssl-on-your-bigbluebutton-server

LG

Holger

https://groups.google.com/forum/#!topic/bigbluebutton-dev/jnXDUWzYnsU

Schau mal hier, ienige mit ähnlichen Problemen

Hallo,

bei mir steht in der /etc/nginx/sites-availible/bigbluebutton
bei
proxy_pass
zweimal:
http://127.0.0.1:5080

und nciht die IP des servers.

LG

Holger

Pakte bbb-html5 wurde beim ugprade auch erst nach ein paarmal installiert, da haengt’s wohl auch mit zusammen, danke fuer die Links, da haette ich ja auch selbst mal schauen koennen. :roll_eyes:

So in etwa, oder?

    location ~ (/open/|/close/|/idle/|/send/|/fcs/) {
       proxy_pass         http://127.0.0.1:5080;
       proxy_pass      https://127.0.0.1:5080;
          proxy_redirect     off;

Dannw warte ich mal auf die 2.2.11 ^^
Ist ja nichts sicherheitsrelevantes

Laeuft halt nicht mehr.

So sieht das bei mir aus:

server {
     listen   80;
     listen [::]:80;
     server_name  meinedomain.de;
     listen 443 ssl;
     listen [::]:443 ssl;
     ssl_certificate /etc/letsencrypt/live/meinedomain.de/fullchain.pem;
     ssl_certificate_key /etc/letsencrypt/live/meinedomain.de/privkey.pem;
     ssl_session_cache shared:SSL:10m;
     ssl_session_timeout 10m;
     ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
     ssl_ciphers "ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS:!AES256";
     ssl_prefer_server_ciphers on;
     ssl_dhparam /etc/nginx/ssl/dhp-4096.pem;
     access_log  /var/log/nginx/bigbluebutton.access.log;

	 # Handle RTMPT (RTMP Tunneling).  Forwards requests
	 # to Red5 on port 5080
      location ~ (/open/|/close/|/idle/|/send/|/fcs/) {
          proxy_pass         http://127.0.0.1:5080;
          proxy_redirect     off;
          proxy_set_header   X-Forwarded-For   $proxy_add_x_forwarded_for;

          client_max_body_size       100m;
          client_body_buffer_size    128k;

          proxy_connect_timeout      90;
          proxy_send_timeout         90;
          proxy_read_timeout         90;

          proxy_buffering            off;
          keepalive_requests         1000000000;
      }

	 # Handle desktop sharing tunneling.  Forwards
	 # requests to Red5 on port 5080.
       location /deskshare {
           proxy_pass         http://127.0.0.1:5080;
           proxy_redirect     default;
           proxy_set_header   X-Forwarded-For   $proxy_add_x_forwarded_for;
           client_max_body_size       10m;
           client_body_buffer_size    128k;
           proxy_connect_timeout      90;
           proxy_send_timeout         90;
           proxy_read_timeout         90;
           proxy_buffer_size          4k;
           proxy_buffers              4 32k;
           proxy_busy_buffers_size    64k;
           proxy_temp_file_write_size 64k;
           include    fastcgi_params;
       }

	# BigBlueButton landing page.
        location / {
          root   /var/www/bigbluebutton-default;
          index  index.html index.htm;
	  expires 1m;
        }

	# Include specific rules for record and playback
        include /etc/bigbluebutton/nginx/*.nginx;

        #error_page  404  /404.html;

        # Redirect server error pages to the static page /50x.html
        #
        error_page   500 502 503 504  /50x.html;
        location = /50x.html {
                root   /var/www/nginx-default;
        }
}

LG

Holger

Mit Chrome geht’s schon wieder, immerhin.
Ich hab jetzt an ein paar Schraeubchen gedreht. Klar ist mal, dass beim Update diesmal mehrere Dateien zurueckgesetzt wurden als sonst, bisher hatte es immer gereicht einfach die turn-stun-servers.xml zurueckzukopieren, diesmal war noch https fuer freeSwitch zurueckgesetzt, mal suchen was noch fehlt.

Danke fuer die superflotte Hilfe.

Gruss Harry

Hallo Harry,

in der Updateanleitung steht, dass man nach einem Update immer
bbb-conf --setip meinedomain.de
machen muss.

Hat das die Probleme bei dir behoben?
LG

Holger

Nein, freeSWITCH war auch noch auf http gestanden.

Ich hab ja in sources.list.d das Repo von BBB drin, ich frag mich wieso ich noch so’n Scheiss machen muss, wenn ich das Repo als Basis fuer Updates nutze.
Ich wuerde mich jetzt mal nicht als Einsteiger bezeichnen und ich geh mal davon aus, dass einige beim ersten Update auf die Schnauze fliegen und dann halt in Zukunft keine mehr machen.
Es haben alle die gleiche Distribution, da koennte man doch eigentlich upgradefeste Konfigdateien schaffen koennen, das Geficke mit apply-config.sh ist ja eigentlich auch eine Krankheit.

Alderalder…jetzt geht Chromium und beim Firefox krieg ich keinen Zugriff auf’s Mikrofon, ich krieg die Krise.

Hallo Harry,

und das wird nirgendwo dokumentiert, was alles angefasst / zurĂĽckgesetzt wird :thinking: :crazy_face:

Man kann ja schlecht jedes mal die ganze manuelle Anleitung durchgehen…

Da werde ich wohl vor der Elternbeiratssitzung nächste Woche respektive den Pfingsterien kein Update am BBB-Server machen.

Viele GrĂĽĂźe
Steffen

Hallo Harry,

bei mir sah es nach dem Update auch so düster aus. Aber ein Neustart von Server und Client hat’s dann gebracht. Läuft wieder so geschmeidig wie vorher.
VG
Christian

Normalerweise ist es ja so, dass ich eigentlich immer irgendwas anders mache als alle anderen und zwar weil ich mich fuer superschlau halte und dabei fliege ich eigentlich so gut wie immer auf die Schnauze, weil ich halt nicht superschlau bin - aber diesmal hab ich eigentlich alles so gemacht wie das in der Doku steht.

Alleine schon, das `bbb-conf --setip hostname_or_ip’ ist ja auch geil, wenn man das nach jedem update machen soll, wieso macht das update das denn nicht?
Macht es einen Unterschied ob hostname oder ip? Es gibt unzaehlige Konfigdateien wo diese Wahl zwischen Gedeih und Verderb entscheidet.
Ich darf nicht meckern, das ist Open Source und ich kann’s ja besser machen - bin froh, dass es das BBB-Coreteam gibt, bzgl, updates gibt’s halt noch Entwicklungsmoeglichkeiten.

Mikro am Firefox geht anscheinend nur bei mir nicht, Kollege mit Windows kommt klar.

Gruss Harry