Apt upgrade mit fehlermeldung nach linuxmuster-prepare

hallo,
komme mit meiner testumgebung (die ova-files vom fleischsalat) nicht weiter:
nach dem linuxmuster-prepare (und reboot) auf dem server endet das apt upgrade mit folgender Fehlermeldung:

`dropbear:WARNING: invalid authorized_keys file, remote unlocking of cryptroot via SSH won’t work

Fehler traten auf beim Bearbeiten von:
linuxmuster-webui7
linuxmuster-base7
linuxmuster-linbo7
E: Sub-process /usr/bin/dpkg returned an error code (1)
`
das manuelle einspielen dieser pakete über dpkg brachte abhängigkeitsfehlermeldungen.

vg
wolfgang

Hallo Wolfgang,

gibt es noch andere Fehlermeldungen? Evtl. hat es damit zu tun: https://github.com/linuxmuster/linuxmuster-linbo/issues/89

vG Stephan

hallo stefan,

gibt es noch andere Fehlermeldungen?

beim direkten aufruf der unkonfigurierten pakete z.b. aufruf apt install linuxmuster-linbo7

l inuxmuster-linbo7 ist schon die neueste Version (2.3.42-1).

Möchten Sie fortfahren? j/n

updating linuxmuster-webui
Deprecation: Python 2.7 will reach the end of life on ....2020 ....
Load existing ajenti config file
copy linuxmuster config in /etc/linuxmuster/webgui/config.yml ---
 Traceback 
File "/usrlib/linuxmuster-webui/etc/split_config_aj.py", line 30, in module 
config_webui [`linuxmuster`]
Key error `inuxmuster`
dpkg: Fehler beim Bearbeiten des Paketes linuxmuster-webui7 (--configure)
Abhängigkeitsprobleme verbleibt unkonfiguriert

Evtl. hat es damit zu tun: https://github.com/linuxmuster/linuxmuster-linbo/issues/89

ehrlich gesagt, ist mir im moment nicht ganz klar, was ich damit machen soll.

vg
wolfgang

Hallo,

ich denke, dass dir @Till oder @Arnaud am besten weiterhelfen können. In einer der letzten Versionen der webUI wurden die config Dateien geteilt, daher der Fehler. Falls es nur ein Testsystem ist, würde ich an deiner Stelle neu anfangen. Entweder selbst aufsetzen oder einmal alles deinstallieren und neu einrichten.

vG Stephan

hallo,
ok. danke. ist ein testsystem. allerdings hilft neu aufsetzen wenig, da dies schon die dritte neu aufgesetzte version ist. mir kommt es so vor, dass im moment jeder in diesen fehler hineinlaufen wird.
vg
wolfgang

Bis jetzt gab es ja noch nicht mal ein Alpha-Release :slight_smile:

Hallo Wolfgang,

Ist die Datei /etc/linuxmuster/webui/config.yml leer ?
Da es um eine Testumgebung geht, kannst du mir bitte den Inhalt von /etc/ajenti/config.yml schicken ?

Erklärungen hier und alternative Lösungen hier : https://github.com/linuxmuster/linuxmuster-webui7/issues/76

Viele Grüße

Arnaud

hallo arnaud,

da ist gar nix im verzeichnis.

Da es um eine Testumgebung geht, kannst du mir bitte den Inhalt von /etc/ajenti/config.yml schicken ?

die config.yml:

auth:
  allow_sudo: true
  emails: {}
  provider: os
bind:
  host: 0.0.0.0
  mode: tcp
  port: 8000
color: default
max_sessions: 9
name: server
ssl:
  certificate: /etc/ajenti/ajenti.pem
  client_auth:
    certificates: []
    enable: false
    force: false
  enable: true

Erklärungen hier und alternative Lösungen hier : https://github.com/linuxmuster/linuxmuster-webui7/issues/76

danke. probier ich noch aus.
vg
wolfgang

guten morgen,

alternative Lösungen hier : https://github.com/linuxmuster/linuxmuster-webui7/issues/76

damit läuft das anschließende upgrade durch. hab aber auch gesehen, dass es seit gestern ein neues paket für die webui gibt.
danke und grüße
wolfgang