7.0 vs. 7.1: global.reg und im.reg -> Domänen-Namen-Verwirrung

Hallo zusammen,

ich bin noch etwas verwirrt, wie/ob beim 7.1 Domänen-Namen in die Regpatches eingetragen werden.

global.reg
In der Datei /srv/linbo/examples/README-regpatches.txt steht

win10.global.reg: Necessary and optional registry entries (see
  comments in the file), which must be imported once before joining the domain
  and creating the image.
  Note: SAMBADOMAIN has to be adapted!

In der Anleitung ist aber keine Rede davon? Muss ich jetzt was händisch ändern?

image.reg
Da hat sich offensichtlich der Inhalt von 7.0 zu 7.1 geändert.
Wichtigste Frage: wenn ich „linuxmuster.lan“ als Domäne gewählt habe, muss dann „linuxmuster“ oder „linuxmuster.lan“ da rein?
Das Beispiel hat ja noch eine Subdomain - da kann ich mir das nicht so recht herleiten :-(…

PS: ich denke mal, der : am Anfang des Codeschnipsels in Punkt 6 (In Zeile 22 musst du noch Folgendes ergänzen:) soll sicherlich ein ; sein - oder?

Merci,
Guntram

Hallo Guntram,

der global.reg muss ins Image: vor der Domänenaufnahme.

Der image.reg muss für das Image bereitgestellt werden und in diesem ist
die Domain an zu passen.
Bei mir steht da in der einen Einrichtung LINUXMUSTER drin und nicht
LINUXMUSTER.LAN
In der anderen steht aber LINUXMUSTER.LAN drin: beides geht, wobei
Buster gerade daruaf hingewiesen hat, dass da eigentlich die lange
Version rein sollte:

https://ask.linuxmuster.net/t/linuxmuster-net-7-1-testing/8265/113

Wichtig ist, dass sich der Namen der image.reg verändert hat.
Während er unter linbo 2.x noch hier lag und so hieß:
/srv/linbo/IMAGENAMEN.cloop.reg
liegt er unter linbo 4.x hier und heißt so:
/srv/linbo/image/IMAGENAMEN/IMAGENAMEN.reg

Es steht also nicht mehr die Imageart im Namen (cloop bzw. qcow2)
Das ist etwas „versteckt“: wurde aber nicht gemacht um die Leute zu
ärgern, sondern hat technische Gründe: die image.reg Datei kann so für
das Baseimage und auch für ein Image (differentielles Image .rsync) gelten.

LG

Holger

Moin!

Ich hatte ja ein neues Win installiert und Image angelegt (orientiert an Windows 10 - Domänen join - Reihenfolge? - #2 von Supergamer) - aber beim Anmelden steht jetzt „Anmelden an SAMBADOMAIN“.

Hat jemand eine Idee, wo da etwas schief gelaufen ist?
System: LMN 7.1 - nicht beta

Danke,
Guntram

Hallo Guntram,

im Kommentar darüber steht in win10.global.reg:

; samba domain, to be adapted

SAMBADOMAIN ist nur ein Platzhalter für den eigenen Sambadomänennamen, der natürlich angepasst werden muss.

Da die Sambadomäne nie geändert wird, reicht es, wenn man sie einmal reinpatcht und dann ein Image macht.

VG, Thomas

Hallo Guntram,

Ich hatte ja ein neues Win installiert und Image angelegt (orientiert an
Windows 10 - Domänen join - Reihenfolge? - #2 von Supergamer
https://ask.linuxmuster.net/t/windows-10-domaenen-join-reihenfolge/8423/2)

  • aber beim Anmelden steht jetzt „Anmelden an SAMBADOMAIN“.

das ist einfach: in deinem global.reg wurde vor dem Einspielen die
Variable SAMBADOMAIN nicht angepaßt.

Schau aber zur Sicherheit auch noch in deine image.reg ob das dort auch
auftaucht.
Wenn es auch in der image.reg steht, dann mimm die Zeilen dort raus.

Zur reparieren:

  1. cleint gesynt booten (neu+start)
  2. also lokaler admin anmelden
  3. global.reg Datei vom Server (mit angepaßter SAMBADOMAIN (steht am
    Ende der Datei drei mal drin) einspielen
  4. IMage erstellen und verteilen.

LG

Holger

Okay. Nachdem Holgers Vorschlag das Anmelden ermöglichte, aber in Windows noch kein Internetzugriff funktionierte, habe ich Windows noch einmal installiert.

Leider das gleiche Phänomen: kein Internet im Browser. Beim Versuch, die Netzlaufwerke zu sehen (im Explorer auf Netzwerk) bekomme ich die Meldung: „Die Netzwerkerkennung ist ausgeschaltet […]“.

Ist das vielleicht ein Hinweis auf mein Problem?

Der Registry-Patch in Linbo4/Abbilder/Einstellungen lautet:

Windows Registry Editor Version 5.00

; linuxmuster.net 7

; patches hostname, to be applied after every image sync

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ComputerName\ActiveComputerName]
„ComputerName“="{$HostName$}"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ComputerName\ComputerName]
„ComputerName“="{$HostName$}"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\services\Tcpip\Parameters]
„Hostname“="{$HostName$}"
„NV Hostname“="{$HostName$}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters]
„NV Hostname“="{$HostName$}"
„Hostname“="{$HostName$}"

; add your custom registry patches below
[HKEY_LOCAL_MACHINE\System\ControlSet001\Services\Tcpip\Parameters]
„Domain“ = „LINUXMUSTER.LAN“

Das müsste doch passen?

Hallo Guntram,

Okay. Nachdem Holgers Vorschlag das Anmelden ermöglichte, aber in
Windows noch kein Internetzugriff funktionierte,

das eine hat mit dem anderen nichts zu tun.

habe ich Windows noch
einmal installiert.

das wird nichts bringen.

Der Internetzugriff läuft über den Proxy (authentifiziert).
Damit da keine Abfrage kommt benötigt man den SingleSignOn.
Es müssen also zwei Dinge geregelt werden:

  1. am Client muss der Proxy eingetragen sein
  2. Die SSO auth muss im Proxy aktiviert sein und funktionieren (auch
    hier: achtet auf die Uhrzeiten von Server, Client und Firewall!)

Siehe hier:

steht das so nicht in der Doku zur INstallation?

LG

Holger

Leider nein. Zumindest nicht auf der offiziellen Strecke: Windows 10 Clients — linuxmuster.net 7.0 Dokumentation

Das müsste dann unbedingt noch ergänzt werden!

Ich dachte, die Proxy-Config wird automatisch gezogen?

Danke schon Mal - ich werde weiter berichten,
Guntram

Hallo Guntram,

schnelle Nachfrage: Um welche Version geht es bei dir? V7.0 oder v7.1?

Liebe Grüße

Thorsten

eine von 7.0 auf 7.1 geupdatete Version.

Frage: ist SSO auch für Ubuntu relevant? Da läuft es ja problemfrei.
Bzw. hat es in der 7.0 ja auch noch funktioniert.

Wenn ich die verschiedenen Tests (kerberos) mache, klappt auch alles.

Wo/wie muss ich den Proxy denn korrekterweise eintragen? Ich habe das jetzt

  • global-admin: Proxyeinstellungen
  • admin defprof.exe
  • global-admin anmelden und dann reboot + Imageerzeugung.

Chrome/Firefox fragen nach erneutem LogIn nach Proxy-Zugangsdaten (und dann geht’s auch).

Ich habe jetzt auf der Firewall keine neue Schlüsseltabelle erzeugt - kann ich das gefahrlos machen oder riskiere ich dann Probleme mit dem Ubuntu-Client?

Ich hasse Windows…
Guntram

Hallo Guntram,

Wo/wie muss ich den Proxy denn korrekterweise eintragen? Ich habe das jetzt

  • global-admin: Proxyeinstellungen
  • admin defprof.exe
  • global-admin anmelden und dann reboot + Imageerzeugung.

Proxyeinstellungen als admin setzen sollte systemweit gelten (für alle).

Chrome/Firefox fragen nach erneutem LogIn nach Proxy-Zugangsdaten (und
dann geht’s auch).

das passiert, wenn die Systemzeiten nicht stimmen: hast du das kontrolliert?
Es ist nicht so einfach Windows bei zu bringen die Systemzeit ordentlich
zu setzen: das mußt du aber machen.

Ich habe jetzt auf der Firewall keine neue Schlüsseltabelle erzeugt -
kann ich das gefahrlos machen oder riskiere ich dann Probleme mit dem
Ubuntu-Client?

das erzeugen der Schlüsseltabellen ist ja beim setup von SSO notwendig:
also mach das.

LG

Holger

Also nicht „global-admin“ sondern der lokale Nutzer „admin“?

Im Prinzip hatte ich das SSO-Setup schon einmal nach dem Upgrade gemacht - ich will mir halt nicht meinen mühsam wieder zusammengezimmerten Server wieder zerschießen. Deswegen noch einmal die Frage: inwiefern könnte das meine Ubuntu-Clients ärgern?

Die Systemzeiten werden gleich angezeigt - das heißt ja allerdings bei Windows nicht viel. Ich hatte den UTC-Fix (siehe z.B. hier: Echtzeit-Uhr unter Windows auf UTC stellen – Georgs Blog) angewandt, damit die Zeiten überall gleich sind.
Gibt es einen Befehl, welcher mir die „echteste“ Information zur Systemzeit unter Windows angibt?

Hallo Guntram,

Also nicht „global-admin“ sondern der lokale Nutzer „admin“?

wurscht: einer von beiden.
Nach dem Image meldest du dich als Domänennutzer an und schaust einfach
nach, ob der Proxy drin ist.

Achte auch drauf, dass im Firefox „Systemproxy verwenden“ drin steht:
nciht dass der das ignoriert.

Im Prinzip hatte ich das SSO-Setup schon einmal nach dem Upgrade gemacht

  • ich will mir halt nicht meinen mühsam wieder zusammengezimmerten
    Server wieder zerschießen. Deswegen noch einmal die Frage: inwiefern
    könnte das meine Ubuntu-Clients ärgern?

so fragil ist das nicht: das kannst du einfach machen.

Bist du den sicher, dass dein ubuntu Client den Proxy verwendet?

Gibt es einen Befehl, welcher mir die „echteste“ Information zur
Systemzeit unter Windows angibt?

unten rechts auf die Uhr schauen reicht.

LG

Holger

Ziemlich sicher. Netzzugang klappt nur mit Schüler oder Lehreraccount. Sonst (linuxadmin) muss ich zur NoProxy-Gruppe (OPNsense) für den jeweiligen Rechner greifen.

Deswegen dachte ich ja, SSO funktioniere. Oder ist das nur für Windows relevant?

Okay…offensichtlich doch noch was tieferliegendes:
Beim „Schlüsseltabelle erstellen“ kriege ich:

Password for global-admin@LINUXMUSTER.LAN:
– init_password: Wiping the computer password structure
– generate_new_password: Generating a new, random password for the computer account
– generate_new_password: Characters read from /dev/urandom = 84
– get_dc_host: Attempting to find Domain Controller to use via DNS SRV record in domain LINUXMUSTER.LAN for procotol tcp
– get_dc_host: Attempting to find Domain Controller to use via DNS SRV record in domain LINUXMUSTER.LAN for procotol udp
– get_dc_host: Attempting to find a Domain Controller to use (DNS domain)
– validate: Error: gethostbyname failed for LINUXMUSTER.LAN

– get_dc_host: Found preferred Domain Controller:
Error: get_dc_host failed

Der Proxy-Eintrag scheint auch nur zu funktionieren, wenn die IP (10.0.0.254) anstatt firewall.linuxmuster.lan eingebe.
Wobei es unter Ubuntu auch mit firewall.linuxmuster.lan funktioniert!

Ideen?

Hallo Guntram,

Der Proxy-Eintrag scheint auch nur zu funktionieren, wenn die IP
(10.0.0.254) anstatt firewall.linuxmuster.lan eingebe.

dann funktioniert DNS unter Windows nicht richtig.
Steht die Netzwerkkarte auf DHCP?
Was ist den da als erster DNS eingetragen?
(Muss die ServerIP sein).

LG

Holger

Hallo Holger,

DHCP ist an, DNS ist 10.0.0.1 (der lmn-Server) :-(…

Aber was ist denn mit den entsprechenden Fehlermeldungen auf Serverseite bei der SSO-Schlüsseltabelle?