Zwei Server-shares mounten: Braucht man pmvarrun?


#1

Hi @roesslerrr (vor allem),

ich habe seit der Problematik mit dem Nicht-Mounten weiterer Samba-shares nach dem ersten nicht weiter mein Problem mit meinem eigenen LehrerServer verfolgt. (https://linuxmuster.net/wiki/anwenderwiki:erweiterungen:samba_lehrernetz)
Jetzt habe ich das nochmal ausgegraben und festgestellt, dass das mounten des LehrerServer-shares nur dann nicht funktionierte, weil es das zweite Mounten war. (alle weiteren Shares vom lmn-server funktionierten jedoch).

Meine pam-mount.xml

<?xml version="1.0" encoding="UTF-8"?>
<pam_mount>
<debug enable="0" />
<mkmountpoint enable="1"/>
<lsof>/usr/bin/lsof %(MNTPT)</lsof>
<fsck>/sbin/fsck -p %(FSCKTARGET)</fsck>
<cifsmount>/usr/sbin/linuxmuster-pam-mount-cifs %(SERVER) %(VOLUME) %(MNTPT) %(USER) "user=%(USER),%(OPTIONS)"</cifsmount>
<lclmount>/usr/sbin/linuxmuster-pam-mount %(SERVER) %(VOLUME) %(MNTPT) %(USER) "%(OPTIONS)" "%(FSTYPE)" </lclmount>
<umount>/usr/sbin/linuxmuster-pam-umount %(SERVER) %(VOLUME) %(MNTPT) %(USER)</umount>
<mntcheck>/bin/mount</mntcheck>
<!--<pmvarrun>/usr/sbin/pmvarrun -u %(USER) -d -o %(OPERATION)</pmvarrun>-->

<volume options="rw,nosuid,nodev,nobrl" user="*" mountpoint="~/Home_auf_Server" path="%(USER)" server="10.16.1.1" fstype="cifs" />
<volume options="rw,nosuid,nodev,nobrl" user="*" mountpoint="~/Privat_auf_Lehrerserver" path="%(USER)" server="10.16.12.100" fstype="cifs" gid="10000"/>
<volume options="username=%(USER),rw,nosuid,nodev,uid=%(USER)" user="*" mountpoint="~/Home_in_Cloud" path="https://cloud.humboldt-gymnasium.ka.schule-bw.de/remote.php/webdav/" server=\
"dummyserver" fstype="davfs"/>
<volume options="rw,nosuid,nodev" user="*" mountpoint="/home/students" path="students" server="10.16.1.1" fstype="cifs" />
<volume options="rw,nosuid,nodev" user="*" mountpoint="/home/share" path="shares" server="10.16.1.1" fstype="cifs" />
<volume options="rw,nosuid,nodev" user="*" mountpoint="/home/samba/progs" path="pgm" server="10.16.1.1" fstype="cifs" />
<volume options="rw,nosuid,nodev" user="*" mountpoint="/home/samba/cds" path="cdrom" server="10.16.1.1" fstype="cifs" />
<volume options="rw,nosuid,nodev" user="*" mountpoint="/var/cache/sophomorix/tasks" path="tasks" server="10.16.1.1" fstype="cifs" />
</pam_mount>

Wie du siehst habe ich jetzt schon pmvvarrun auskommentiert, nur dann kriege ich es hin, dass sowohl Home_Auf_server als auch “Privat_auf_LehrerServer” gemountet werden.
Wenn pmvarrun drin ist, wird nur das gemountet, was als erstes kommt.
Hintergrund ist, dass derselbe User über LDAP jeweils von SMB-server abgefragt wird. Aber vermutlich ist das Problem eben lokal auf dem Client, weil pmvarrun den Counter hochzählt.

Also die Frage: Kann ich pmvarrun einfach rauslassen?

VG, Tobias


#2

Hallo Tobias!

Unsere pam_mount.xml sieht etwas anders aus.
Statt der zwei Zeilen

||| <cifsmount>/usr/sbin/linuxmuster-pam-mount-cifs %(SERVER) %(VOLUME) %(MNTPT) %(USER) "user=%(USER),%(OPTIONS)"</cifsmount>|| <lclmount>/usr/sbin/linuxmuster-pam-mount %(SERVER) %(VOLUME) %(MNTPT) %(USER) "%(OPTIONS)" "%(FSTYPE)" </lclmount>||| ||

die bei dir stehen, haben wir stattdessen nur eine |

|| <cifsmount>/usr/sbin/linuxmuster-pam-mount %(SERVER) %(VOLUME) %(MNTPT) %(USER) "user=%(USER),%(OPTIONS)"</cifsmount> ||

Wo kommen diese geänderten/zusätzlichen Einträge bei dir her?
(Bei uns sollte eigentlich der Standard aus dem linuxmusterclient-Paket vorliegen.)
Vielleicht liegt darin die Ursache?

Alles andere ist jedenfalls wieder gleich - nicht identisch, aber sinngemäß gleich. :wink:

Eine Sache war, so meine ich mich zu erinnern, dass man die tasks als letztes Verbinden muss,
da Einträge danach nicht funktionieren. (Das ist bei dir aber so. Nur vielleicht war es zwischenzeitlich mal anders?)

<volume options="rw,nosuid,nodev" user="*" mountpoint="/var/cache/sophomorix/tasks" path="tasks" server="10.16.1.1" fstype="cifs" /> ||| (Anmerkung: Das habe ich nie genau analysiert.) ||
GruĂź - Rainer


#3

Hi Rainer,

ok. Das sieht so aus, als ob ich eine alte Version mitgeschleift habe, die noch linuxmuster-pam-mount-cifs und linuxmuster-pam-mount unterscheidet. Ich denke nicht, dass ich mir das ausgedacht hatte.
Ich vergleiche mal die aktuellen linuxmuster-client-… Pakete.

Allerdings habe ich auch als einziger (vielleicht?) zwei CIFS mounts mit demselben sharename (PATH) und verschiedenen Servern. Eventuell denkt pmvarrun, dass ich zwei mal dasselbe share mounten will, auch wenn es auf verschiedenen Servern ist.

Ich hab auch keine Ahnung warum es erst seit dem kernel-update nicht mehr tat, wo auch das mit den tasks im Klassenarbeitsmodus (inkl. dem 30-sekunden-workaround) wegen der multiplen Prozesse aufkam.

Du weiĂźt also auch nicht, ob was dagegen spricht pmvarrun auszublenden?

Danke fĂĽr die hinweise!

Tobias


#4

HI Rainer,

leider muss ich sagen: es tut nun. Ich habe den Client nochmal gebootet, egal ob mit oder ohne Kommentar fĂĽr pmvarrun: es funktioniert einfach wieder.
Vielleicht hat es Rückkopplungen gegeben vom zweiten Server, dessen smbpasswd am anfang neu gesetzt werden musste oder was weiß ich, jedenfalls tut es vorläufig. Hoffe das bleibt so.

Danke fĂĽrs Mitdenken!


#5

Hallo Tobias!

Wir verbinden auch ein separates lehrershare im Lehrernetz auf einer
Extramaschine und es funktioniert - so wie bei dir jetzt auch.

Abwarten, Tee trinken. :wink:

GruĂź - Rainer


#6

Ah, dann kann ich ja auch nochmal … ah ne vergiss es. Holger erwähnte dass es da so eine Testschule gäbe für die 7… ich ziehe alle Fragen zurück.

(ich musste auf dem lehrernetz-samba einmal das LDAP-admin passwd nochmal mit smbpasswd eingeben und musste ihm noch “netbios name = SCHULE” hinzufügen, was ich vorher nicht hatte, damit die SIDs korrekt(er) waren, die er verglich… Gottseidank funktioniert es jetzt einfach, sonst hätte ich weder Zeit noch Lust das zu debuggen.)

VG, Tobias