WebUI: Warnungen bei Upgrade auf WebUI 7.2.18

Hallo @Arnaud.
Ich habe gerade ein Upgrade auf die aktuelle WebUI angeworfen. Dabei erhielt ich einige Warnungen - das meiste davon dürfte nicht dramatisch sein aber ich gebe die Meldungen dennoch kurz hier weiter. Wer weiß…

     Successfully uninstalled pip-23.1.2
  WARNING: The scripts pip, pip3 and pip3.10 are installed in '/usr/local/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed pip-23.2.1
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv

Remove deprecated plugins

WARNING: Skipping ajenti.plugin.auth-users as it is not installed.
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv

Backing up and updating config.yml


Check requirements

WARNING: Skipping gevent-socketio-hartwork as it is not installed.
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv

...
Downloading Pillow-10.0.0-cp310-cp310-manylinux_2_28_x86_64.whl (3.4 MB)
   ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 3.4/3.4 MB 13.1 MB/s eta 0:00:00
DEPRECATION: distro-info 1.1build1 has a non-standard version number. pip 23.3 will enforce this behaviour change. A possible replacement is to upgrade to a newer version of distro-info or contact the author to suggest that they release a version with a conforming version number. Discussion can be found at https://github.com/pypa/pip/issues/12063
DEPRECATION: gpg 1.16.0-unknown has a non-standard version number. pip 23.3 will enforce this behaviour change. A possible replacement is to upgrade to a newer version of gpg or contact the author to suggest that they release a version with a conforming version number. Discussion can be found at https://github.com/pypa/pip/issues/12063
Installing collected packages: Pillow
Successfully installed Pillow-10.0.0
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv

Set default sophomorix webui rights

...

linuxmuster-prepare (7.2.2-0) wird eingerichtet ...
Requirement already satisfied: reconfigure in /usr/local/lib/python3.10/dist-packages (0.1.82)
Requirement already satisfied: chardet in /usr/lib/python3/dist-packages (from reconfigure) (4.0.0)
DEPRECATION: distro-info 1.1build1 has a non-standard version number. pip 23.3 will enforce this behaviour change. A possible replacement is
to upgrade to a newer version of distro-info or contact the author to suggest that they release a version with a conforming version number.
Discussion can be found at https://github.com/pypa/pip/issues/12063
DEPRECATION: gpg 1.16.0-unknown has a non-standard version number. pip 23.3 will enforce this behaviour change. A possible replacement is to
upgrade to a newer version of gpg or contact the author to suggest that they release a version with a conforming version number. Discussion
can be found at https://github.com/pypa/pip/issues/12063
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is re
commended to use a virtual environment instead: https://pip.pypa.io/warnings/venv

Alles normal soweit? Oder muss ich da noch etwas im Hintergrund aktualisieren?
Viele Grüße,
Michael

Hi Michael,

Ich sehe hier kein Problem.

Gruß

Arnaud

Ok! Danke!