V7: Server meldet Quota-Fehler

UUID=593b990a-5bef-4d1d-b7da-07a266ae0603	/	ext4	user_xattr,acl,usrquota,usrjquota=aquota.user,grpquota,grpjquota=aquota.group,jqfmt=vfsv0,errors=remount-ro,barrier=1	0	0
UUID=7a521446-4042-4a48-9788-f47ba3042b45	/boot	ext4	defaults	00
/swap.img	none	swap	sw	0	0

Bei mir fehlen die Dateien auch und systemctl status quotaon.service bringt die gleichen Fehlermeldungen!?

Warum sind die bei Euch da und bei uns nicht?
Habt Ihr die fertigen Appliances genommen?
Wir haben den Server from scratch installiert.
Was haben die für einen Inhalt? Sind die systemspezifisch oder könntet Ihr uns die einfach bereitstellen?

Wär ja aber schon interessant, herauszubekommen, woran das liegt!?

LG,
Jochen

Hallo,

auch ich habe from Scratch installiert und dabei darauf geachtet, dass
es die Partitionen, wie sie in der ova vorliegen, auch bei mir gibt.
Das habe ich so gemacht, nachdem mir Maurice hier in ask dazu geraten
hat, da das Quota Konzept der lmn7 das so vor sieht.
Also habe ich folgende Partitionen:
UUID=a06f2ba7-4970-441c-a41b-6ecd90dc8061 / ext4
user_xattr,acl,usrquota,usrjquota=aquota.user,grpquota,grpjquota=aquota.group,jqfmt=vfsv0,errors=remount-ro,barrier=1
0 0
/swap.img none swap sw 0 0
/dev/vdb1 /var ext4 defaults 0 1
/dev/vdb2 /srv/linbo ext4 defaults 0 1
/dev/vdb3 /srv/samba/global ext4
user_xattr,acl,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,barrier=1
0 1
/dev/vdb4 /srv/samba/schools/default-school ext4
user_xattr,acl,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,barrier=1
0 1

Drei davon sind quotiert.

Bei mir fehlen die Dateien auch und systemctl status quotaon.service
bringt die gleichen Fehlermeldungen!?

wie hast du Partitioniert?

Warum sind die bei Euch da und bei uns nicht?

ich nehme an, weil du auch nur eine Partition hast.

Habt Ihr die fertigen Appliances genommen?

nein.

Wir haben den Server from scratch installiert.

ja

Was haben die für einen Inhalt?

binär.

Sind die systemspezifisch oder könntet
Ihr uns die einfach bereitstellen?

weiß ich nicht.

Wär ja aber schon interessant, herauszubekommen, woran das liegt!?

an eurer Partitionierung, denke ich.

LG

Holger

Hallo Holger,

vermute ich auch. Wir haben nur eine große Partition.

Jetzt ist die Frage: was tun!?

Nur die neuen Partitionen anlegen wird da wohl nicht reichen? Neuinstallation???

Viele Grüße,
Jochen

Hallo Jochen. Habt ihr virtualisiert? Dann kannst du doch nachträglich „beliebig“ viele virt. Platten hinzufügen und die fstab entsprechend anpassen?

Hallo Michael,

ja, haben wir :wink:
Puh, ziemlich steinig dieser Weg.

Aber nur durch Anlegen der Partitionen dürften sich die beiden Dateien nicht automatisch dorthin bewegen, oder!? Könntet Ihr uns Eure Dateien zur Verfügung stellen? Evtl. von Michael und Holger, damit wir (anhand der Größe?) sehen können, ob sie systemspezifisch sind oder nicht.

Vielen Dank und viele Grüße,
Jochen

Hallo Jochen.
Ja, der Weg ist steinig … stelle ich auch fest. :wink:

Wahrscheinlich ist es nicht schlau, die Files einfach zu kopieren. Stattdessen steht hier der elegantere Weg unter:

Automatisches Erstellen der Dateien aquota.user beziehungweise aquota.group

https://wiki.ubuntuusers.de/Quota/

hth?
Michael

äääh, wie sieht denn der ungefähre weg für mich aus? kann das irgend jemand überhaupt sagen??? hat die fstab eine aussage für die wissenden?
gruß,
h.

Hallo „h“.
Die fstab hatte Holger oben ja bereits gepostet. Die entscheidenden Einträge dort sind:

Also alle Mountpoints, die so eine Option haben, werden per Quota überwacht. Macht das die Sache klarer?

Hast du virtualisiert oder auf bare-metal installiert?
Michael

Hallo Michael,

Hast du virtualisiert oder auf bare-metal installiert?

virtualisiert mit KVM

LG

Holger

Hallo Hendrik,

äääh, wie sieht denn der ungefähre weg für mich aus?

man fährt den Server herunter und „baut“ eine neue Festplatte ein.
Dann bootet man ihn und wechselt in den singleusermode.
Dann partitioniert und formatiert man die neue Platte.
Danach bewegt man die Dateien von den Pfaden der alten Platte auf die
jeweils neue Partition.
Dann trägt man die zusätzlichen mountpoints in der fstab ein und bootet neu.
Hat man alles richtig gemacht, dann bootet der server ganz normal und
man hat die Daten ausgelagert.
Jetzt kann man die aquota.* Dateien anlegen und den Server nochmal neu
starten.

kann das irgend
jemand überhaupt sagen???

ja: ich …

hat die fstab eine aussage für die wissenden?

na hoffentlich, sonst wäre sie ja Sinnlos :slight_smile:
Ich trau mir zu sie zu „lesen“: schick doch mal …

LG
Holger

Hi,

ich klink mich kurz für/bei Jochen ein.
Wir haben das LVM und /etc/fstab wie oben beschreiben angepasst & die Quotas funktionieren jetzt.

Was ich aktuell aber noch nicht finde, ist wie man in der WebUI die Quota setzt.
Im Reiter „Quota“ kann ich die Werte zwar anpassen, aber finde keine Option die Anpassungen zu übernehmen.

Und auf der Shell sehe ich zwar die Quotas für Rollen (student, teacher, usw.) in der school.conf von Sophomorix,
aber nicht die Möglichkeit dies für einzelne Benutzer anzupassen.

Wo kann ich das anpassen und wie funktioniert hier die WebUI?

LG
Xandra

hi holger,
s. mein post oben, fstab schon geschickt! ja ich weiss „hat die fstab eine aussage…“ war doof formuliert. ich wollte natürlich hier konkretere antworten hören!
zum glück lvm…

ich von meiner seite aus als nicht-lmn-profi fände es gut, wenn das standardmäßig implementiert wäre. denke aber, dass das bestimmt kommt oder? sonst wäre das ein feature-request für mich jedenfalls.

Hallo Hendrik,

ich von meiner seite aus als nicht-lmn-profi fände es gut, wenn das
standardmäßig implementiert wäre. denke aber, dass das bestimmt kommt
oder? sonst wäre das ein feature-request für mich jedenfalls.

was soll standartmäßig implementiert sein?
Quota?
Ist doch drin??

LG

Holger

Hallo Xandra,

sophomorix-quota --help
ist dein Freund.

Die Quotavorgaben werden hier eingetragen:

/etc/linuxmuster/sophomorix/default-school/school.conf

und dann mit sophomorix-quota gesetzt.

Vielelicht geht das auch schon in der WebUI …
LG

Holger

Hallo,
kleine Ergänzung, weil wir die gleichen Fehlermeldungen unter v7 hatten.
In der /etc/fstab/ sollten nur die Einträge mit „j“ (=journaled quotas) stehen, nicht die ohne (und nicht beide gleichzeitig):

usrquota                   > veraltet
usrjquota=aquota.user      > aktuell und richtig
grpquota                   > veraltet
grpjquota=aquota.group     > aktuell und richtig

Die jeweiligen Dateien sollten eher erzeugt werden per quotacheck -avugm
da sie individuelle parameter beinhalten (nicht kopiert).
Ich musste vor einem Status check zB per quotaoff -av zuerst die Quotas deaktivieren, dann
per systemctl restart quotaon.service neu starten, dann war der Status wieder „active
Mal sehen, ob das nach dem nächsten reboot auch noch passt…
[EDIT]: ja, passt auch nach reboot noch.

Grüße,
gerd

1 Like

Bei uns stehen beide Einträge drin (aber nur an einer Stelle und zwar für den mountpoint von / ) … den alten (doppelten) Eintrag habe ich gerade rausgeworfen.
Hoffe, dass ich (bis auf einen Neustart) dann nichts weiter machen muss…
Schöne Grüße,
Michael

Hallo Michael,

ja, ich vermute, dass die per default zumindest bei der root „/“ überall drin stehen.
So wie ich die Dokumentation verstehe, ersetzen die journaled quotas die alten Einträge ohne „j“.

Grüße,
gerd

… aber du bist sicher, dass sie nicht doppelt dahin gehören, ja?

ja :wink:

(was ich aber nicht sicher weiß, was linux macht, wenn beides drinn steht.
Hier vermute ich, dass Linux die aktuelleren Einträge bevorzugt und die alten dann ignoriert, ist aber eher eine akademische Frage…) raus damit.