Testen von v7 in Virtualbox

Holger @baumhof hat netterweise eine Testumgebung für Version 7 zur Verfügung gestellt, die man nur in Virtualbox importieren muss - sehr schick.

Ich habe dazu eine Menge Fragen (die zum Teil gar nichts mit Linuxmuster zu tun haben, sondern eher mit Virtualbox).

Gleich die ersten beiden:

  • Der Server ist nicht im Internet. Das ist sicher eher ein Virtualboxproblem. Muss ich dem Server eine zusätzliche Netzwerkkarte spendieren, oder nur irgendwo ein Häkchen setzen?
  • Mit dem Client (ich habe den Ubuntu-Client mit Linbo installiert, läuft) komme ich nicht auf ein Admininterface. Per ifconfig auf dem Server habe ich schon die IP Adresse des Servers rausgefunden, aber da läuft keine Seite. Muss ich da noch was starten?

Hallo,

ich kenne jetzt Holgers Testumgebung nicht, deshalb etwas ins Blaue :slight_smile:

Eigentlich nicht. Hast du die Firewall-VM auch gestartet?

Normalerweise https://SERVER-IP:8000 (falls das Setup noch nicht ausgeführt wurde, nur http (ohne “s”))

vG Stephan

Ah, die Firewall ist auf einer Extramaschine. In Holgers Umgebung sind noch lmn7-docker und lmn7-opensense .

Welche davon ist die Firewall? lmn7-opensense macht übrigens eine Fehlermeldung beim Hochfahren:

Während der Ausführung der virtuellen Maschine ist ein Fehler aufgetreten. Einzelheiten werden unten gezeigt. Sie können versuchen, den angezeigten Fehler zu beheben und mit der Ausführung fortzufahren.

The I/O cache encountered an error while updating data in medium “lsilogicscsi-0-1” (rc=VERR_DEV_IO_ERROR). Make sure there is enough free space on the disk and that the disk is working properly. Operation can be resumed afterwards.

Fehler ID: BLKCACHE_IOERR
Dringlichkeit: Normaler Fehler

Ok, auf das Admin-Interface komme ich jetzt.
Internet habe ich keines, im Admin-Interface sehe ich, dass die free-BSD-Maschine die Firewall ist. Was da los ist, weiß ich leider nicht. Genügend Platz ist auf meiner Partition schon, wenn, dann müsste die virtuelle Festplatte zu klein sein.

Hallo Andreas,

ohen OPNsense gibts kein INternet in der virtuellen Umgebung :slight_smile:

Bitte schalt mal bei der OPNsense unter “Massenspeicher” den Host IO
Cache des SCSI Controllers aus.
Ich hatte es schon auf anderen Rechner, dass die OPNsense damit die
Festplatte nicht findet (beimeinem Ryzen Zuhause geht es so).

Falls das nciht hilft, nimm auch noch den Haken bei der Festplatte
selbst raus, dass sie eine SSD ist.

Danch mal booten.

LG

Holger

Der Cache WAR aus. Einer Eingebung folgend habe ich in AN geschaltet, jetzt gehts! Auf dem Server habe ich jetzt Internet, auf dem Client muss ich noch probieren.

Etwas erstaunlich ist, dass der Client echt ewig zum Booten braucht.

Edit: Ja, Netz geht auch im Client.

Ok, nun die nächste Übung: Einen eigenen Client (Linux) designen.
Schritte:

  1. Neuen Rechner anlegen, dafür neuen Typ festlegen (anderes Image)
  2. Diesen auch in Virtualbox anlegen
  3. Einmalig diesen über PXE starten
  4. Nachdem Linbo einmal gelaufen ist, den Rechner vom Installationsmedium starten
  5. Nach der Installation das .deb Paket von Linuxmuster laufen lassen
  6. Wenn alles geht, davon ein Image erstellen

Richtig?

Hallo Andreas,

Etwas erstaunlich ist, dass der Client echt ewig zum Booten braucht.

du meinst den ubuntu Client.
Ja: da sit noch ein Fehler drin.
Du mußt in der /etc/fstab auf dem Client beim swap noch aus der UUID die
korrekte Partition machen: also sda3 oder so (weiß ich gerade nicht
auswendig).
Dann hängt er nicht so ewig beim booten

LG

Holger

1 Like

Hallo,
zwei Fragen zur Testumgebung:

  1. Nach längerer Abwesenheit teilte mir der Anmeldemanager des Clients mit, das Passwort sei abgelaufen. Wie kann man das abstellen?
  2. Wie update ich den Server?

Dank + Gruß, Andreas

Hallo,

siehe hier: Userpasswörter laufen ab!

und hier: https://github.com/linuxmuster/sophomorix4/issues/71#issuecomment-515749767

auf der Konsole:

linuxmuster-distupgrade

VG

Dominik

1 Like

Vielen Dank! Ich update gerade.

Ein völlig anderes Problem: Ich möchte gerne Kubuntu - Clients nutzen. Die Domänenaufnahme funktioniert nicht mit dem Login-Manager sddm, aber sie geht mit gdm3. Installiert man aber gdm3, wird sehr viel von gnome mitinstalliert, was ich gerne vermeiden möchte.

Ich möchte daher testen, ob die Domänenaufnahme auch mit lightdm funktioniert, aber ich bekomme bei einem Kubuntu lightdm nicht installiert. Es fehlt bei Kubuntu 18.04 das Paket “lightdm-kde-greeter”, das man wohl eigentlich bräuchte.

Also: Hat hier jemand ein Kubuntu 18.04 mit lightdm laufen, wenn ja: Wie installiert man das korrekt? (einfach lightdm installieren liefert ein session failed bei der Anmeldung). Falls nein, frage ich das bei askubuntu.

Lieber Andreas ,
Kubuntu verwendet normalerweise sddm, daher ist der lightdm nicht so gut unterstützt. (Aus der Ferne und ohne Computer) kannst Du folgendermaßen vorgehen:
Zuerst lädst Du Dir die benötigten Dateien /packages von lightdm herunter:

apt-get download lightdm*

dann installierst Du sie und ignorierst die Abhängigkeiten:

dpkg --force-all -i <lightdmirgendwas>.deb

und schließlich musst Du die Konfigurationsdatei so umstellen, dass ein anderer greeter verwendet wird:
(aus askubuntu):

Just edit the greeter-session option in /etc/lightdm/lightdm.conf to the desired greeter.

If you for example want to use the lightdm-gtk-greeter .

Open up ‘/etc/lightdm/lightdm.conf’ with any editor as root. For example sudo vim /etc/lightdm/lightdm.conf then change the line

greeter-session=unity-greeter

to

greeter-session=lightdm-gtk-greeter

If the file does not exist, let it contain

[SeatDefaults]
greeter-session=lightdm-gtk-greeter

Then all you have to do is make sure that the greeter is installed (e.g. the package lightdm-gtk-greeter ) and then restart lightdm.

liebe Grüße Christoph

Hallo Christoph,
vielen Dank. Das Problem steckt aber im Detail: Hier wird ja erklärt, wie man auf den lightdm-gtk-greeter umstellt, für KDE braucht man aber den lightdm-kde-greeter, und dieses Package gibt es nicht mehr.

Die andere Idee wäre (und das wäre mir auch lieber): Kann man die lm7 Domänenaufnahme so anpassen, dass sie auch mit sddm funktioniert?

Ok, erst mal als Workarund: Ich habe die anderen x-sessions (also alle außer Plasma) in /usr/share/xsessions auf dem Client gelöscht. Es erscheint zwar immer noch Ubuntu-Wayland als Auswahlmöglichkeit (keine Ahnung warum, vermutlich sind wayland-sessions noch woanders hinterlegt), aber Plasma ist jetzt default. Ich muss keine Angst mehr haben, dass User sich in Gnome einloggen (was ja gar nicht vollständig installiert ist bei mir). Schön ist es nicht (der login-Screen passt überhaupt nicht vom Thema), aber es ist kein Showstopper mehr.

Hi,

ich habe das so verstanden, dass letztendlich egal ist, welchen greeter man nimmt: man kann sogar selbst einen erstellen liebe Grüße Christoph

Ich habe das mit dem lightdm jetzt erst mal hinten angestellt (habe eine Frage auf askubuntu gestellt, aber noch keine Antwort bekommen).

Ansonsten läuft mein Kubuntu Client jetzt gut. Welche Schritte müsste ich unternehmen, um diesen nun von meinem Rechner (wo er ja ein virtuelles System ist, ferner als cloop image auf meinem virtuellen Server liegt) in meine Schule zu bekommen?

Dank + Gruß, Andreas

Hallo,
ich habe es jetzt auch mit lightdm hinbekommen. Das ist auch gut so, weil für gdm3 eine komplette gnome-Session startet, die dann auch im Hintergrund weiterläuft und Speicher frisst.

So gehts:

Wenn man Kubuntu lokal installiert benötigt man, um lightdm verwenden zu können, folgenden Workaround:

Anschließend installiert man das linuxmuster-package, und die Anmeldung funktioniert auch weiterhin mit lightdm.

Ich habe dann noch ewig gefummelt, um den slick-greeter zum Laufen zu bekommen und das Schullogo einzupflegen, wer da Interesse hat, möge nachfragen.

Gibt es eine Stelle hier bei LInuxmuster, wo ich das kubuntu.cloop hochladen könnte? Falls das jemand noch haben möchte (war insgesamt recht viel Arbeit).

Ich muss jetzt auch noch sehen, wie ich das in unsere Schule transferiert bekomme und ob es auch auf allen Rechnern vernünftig läuft.

Hallo Andreas,

Ich habe dann noch ewig gefummelt, um den slick-greeter zum Laufen zu
bekommen und das Schullogo einzupflegen, wer da Interesse hat, möge
nachfragen.

Gibt es eine Stelle hier bei LInuxmuster, wo ich das kubuntu.cloop
hochladen könnte? Falls das jemand noch haben möchte (war insgesamt
recht viel Arbeit).

da arbeiten wir noch dran.
Erstmal ist es super, wenn du es, wie du oben beschrieben hast, einfach
hier im Forum per PM raus gibst.
Wenn du es nicht selbst zum Download bereitstellen willst, dann lass es
mir zukommen und ich stelle es zur Verfügung (über eine Nextcloud).

Ich muss jetzt auch noch sehen, wie ich das in unsere Schule
transferiert bekomme und ob es auch auf allen Rechnern vernünftig läuft.

das ist einfach:

  1. transferier alle .cloop* Dateien vom virtuellen auf das
    echte System nach /srv/linbo/
  2. pass die Rechte dieser Dateien an (ichmeine 644 ist korrekt)
  3. lösch die .macct Datei
  4. bespiel einen Client mit dem Image und tritt der Domäne bei
  5. erstell ein Image.

LG

Holger

Hallo Holger,
wo liegt diese .macct Datei?

Ich habe es mit dem Cloop jetzt noch ganz anders gemacht: Ich habe den Netzwerkadapter einfach auf Brücke umgestellt und die virtuelle Maschine im Schulnetz gebootet. Linbo startet per pxe, dann konnte ich das Image direkt per Linbo hochladen (spricht da was dagegen)? Ich habe aktuell auch gar keinen root-Zugriff auf den Server.

Konkret zu der Testumgebung: ich bekomme innerhalb der Virtualbox-Testumgebung erhebliche (!) Netzwerkprobleme, wenn ich den Einstellungen-Ordner auf dem Server verwende (also zB. einen Link auf .config setze). Noch schlimmer ist das, wenn ich force-localhome auf „no“ setze. Dann bleibt das komplette Netzwerk länger hängen, die Clients auch, und auf der Konsole des Clients sehe ich Fehlermeldungen

CIFS VFS: SMB signature verification returned error = -13

Das passiert sowohl mit meinem Client als auch mit dem von Dir bereitgestellten „normalen“ Ubuntu-Client.

Ist das bei Dir auch so? Liegt das, falls ja, an der virtuellen Umgebung, oder gibt es da ein Problem mit den Netzwerkeinstellungen des Linux-Clients? Das mounten von Samba-Shares in Linux mit cifs ist ja nicht ganz unumstritten, in den meisten Fällen bietet nfs die bessere Performance. So richtig happy bin ich mit dem Verwenden von Samba für Linux Clients an einem Linux Server noch nicht, ich hoffe, ich werde hier noch eines Besseren belehrt :wink:

Viele Grüße, Andreas

Hallo Andreas,

wo liegt diese .macct Datei?

in /srv/linbo/

Ich habe es mit dem Cloop jetzt noch ganz anders gemacht: Ich habe den
Netzwerkadapter einfach auf Brücke umgestellt und die virtuelle Maschine
im Schulnetz gebootet. Linbo startet per pxe, dann konnte ich das Image
direkt per Linbo hochladen (spricht da was dagegen)?

nein: kann man so machen: ist sogar „elegant“ :slight_smile:

Konkret zu der Testumgebung: ich bekomme innerhalb der
Virtualbox-Testumgebung erhebliche (!) Netzwerkprobleme, wenn ich den
Einstellungen-Ordner auf dem Server verwende (also zB. einen Link auf
.config setze). Noch schlimmer ist das, wenn ich force-localhome auf
„no“ setze. Dann bleibt das komplette Netzwerk länger hängen, die
Clients auch, und auf der Konsole des Clients sehe ich Fehlermeldungen

CIFS VFS: SMB signature verification returned error = -13|

Das passiert sowohl mit meinem Client als auch mit dem von Dir
bereitgestellten „normalen“ Ubuntu-Client.

Ist das bei Dir auch so?

weiß ich nicht, weil ich die Homes lokal auf dem Client haben will.
Das was du da erzählst mit nfs gemounteten Homes vom Server hatten wir
auch mal im linuxclient (gut: es war nicht NFS sondern cifs) und es war
furchtbar.
Deswegen bin ich stark für die Lösung, wie wir sie beim letzten
linuxmuster Client hatte: da war der Client überhauptnicht in der Domäne
und es wurde nur das Home vom Server lokal in den Ordner Home_auf_Server
gemountet und ein paar lokale configverzeichnisse in dieses Verzeichnis
verlinkt.
Das war sehr robust: einfach Genial: Jahre lang.
Jetzt haben wir die Domänenanmeldung: gut, geht nicht anders.
Aber wir versuchen immernoch das Serverhome möglichst seperat zu halten:
aus guten Gründen und nach Jahrelanger Erfahrung.

Wenn du in der Richtung testen willst: dann mach das, aber ich habe
keine Lust nochmal in diese Richtung zu gehen … sorry :slight_smile:

LG

Holger

Hallo Holger,
klar, die „richtig“ gemounteten Homeverzeichnisse haben Vor- und Nachteile.

In diesem Fall ist es aber so, dass ich das ja so machen wie von Linuxmuster angedacht: Ich binde nur .local und .config ein! Trotzdem hängt es.

Hast Du in Deiner virtuellen Umgebung auch schon mal diese Konfigurationsverzeichnisse verlinkt?