Schulkonsole - Lehrer kann Internet nicht freischalten

Hallo, brauche Hilfe!

Nach dem Update auf 6.2 kann man als Lehrer das Internet für die Schüler nicht freischalten.
Nach dem Klick auf Änderungen übernehmen zeigt der Browser an, dass er verbindet und verbleibt in diesem Zustand. Man kann keine weitere Aktion durchführen, sich auch nicht abmelden. Es bleibt nur noch den Browser zu schließen.
Hat jemand eine Idee, woran das liegen könnte?

Gruß
Jürgen

Hallo!
Ganz selten ist es bei mir so, dass man da sehr lange warten musste (ca 5 min).
Probier doch mal… Vll gehts dann wieder schneller.
Ansonsten würde ich auf dem Server mit den sophomorix-Befehlen auf Fehlersuche gehen. sophomorix-room glaube ich.

lg Max

Hallo Max,

danke für die schnelle Antwort.
Ich weiß aber nicht, was du mit “VII” meinst.

Gruß
Jürgen

Hallo Jürgen,

ich nehme an Max meint „vielleicht“, im SMS-Jargon abgekürzt zu „vllt“” oder „vll“. Dabei muss man doch dank WhatsApp & Co heute gar keine Zeichen mehr sparen :slight_smile:

Grüße,
Sven

Hallo Jürgen,

bitte teste mal, ob der Passwortlose ZUgang zum IPFire funktioniert.

ein

ssh -p 222 ipfire
sollte dich vom Server aus ohne Passwortabfragen auf den IPFire bringen.
Wenn das geht: mit
exit
geht es zurück.

Bitte schreib uns auch mal, welche IPFire Version du hast: das sieht man
auf der Weboberfläche des IPFire

Viele Grüße

Holger

Hallo Sven, hallo Holger,

danke für eure Antworten.
Der ssh-Zugang funktioniert, die ipfire-Version ist:

IPFire 2.19 (i586) - Core Update 102

Außerdem funktioniert jetzt auch die Schulkonsole wieder, wie bisher von der lmn 6.1 gewohnt, nachdem der IPFire “neu initialisiert” wurde.

Mich würde jetzt noch interessieren, ob es normal ist, wenn die Verbindungsdauer beim Freischalten des Internets für die Schüler etwas länger dauert (schätze ca. 20 Sekunden)?
Wenn nicht, wie kann man das beschleunigen?

Danke für eure Hilfe
Jürgen

Hallo!

bei mir dauert das Freischalten auch so geschätzt 15 Sekunden. Instantan geht es jedenfalls nicht.

LG
Max

Ich vermute mal, dass es hiermit zu tun hat: https://github.com/linuxmuster/linuxmuster-base/pull/43

Hallo zusammen,

bei meiner LML 6.2 habe ich das Problem, dass ich als Lehrer das Internet nicht freischalten kann. D.h. ich setze in der Schulkonosle die Haken und gehe auf anwenden. Der Schüler-PC bleibt trotzdem vom Internet ausgesperrt. Ebenso verhält es sich mit dem Lehrer-PC, der eigentlich dauerhaft im Internet sein könnte, da ich für diesen eine Ausnahme in der Schulkonsole erstellt habe. Da ich leider mit Win10 weiterhin auf dem Kriegsfuß bin (s. Thread “Schulnosole nur über IP erreichbar”) (DNS-Problem oder nicht???), bin ich etwas ratlos welche Schraube ich noch testen kann.
Meinen IPFire 2.19 (64-bit) - Core Update 105 kann ich vom Schülerserver aus mit ssh -p 222 ipfire ohne Probleme ansprechen. Ich habe auch länger als 5 Minuten gewartet (genauer gesagt: 35 Minuten) es hat sich trotzdem nichts getan, Ein Neustart vom IP-Fire hat auch nichts gebracht.

Danke für Eure Tipps
HAL

Hallo HAL,

bei meiner LML 6.2 habe ich das Problem, dass ich als Lehrer das
Internet nicht freischalten kann. D.h. ich setze in der Schulkonosle die
Haken und gehe auf anwenden. Der Schüler-PC bleibt trotzdem vom Internet
ausgesperrt. Ebenso verhält es sich mit dem Lehrer-PC, der eigentlich
dauerhaft im Internet sein könnte, da ich für diesen eine Ausnahme in
der Schulkonsole erstellt habe. Da ich leider mit Win10 weiterhin auf
dem Kriegsfuß bin (s. Thread “Schulnosole nur über IP erreichbar”)
(DNS-Problem oder nicht???), bin ich etwas ratlos welche Schraube ich
noch testen kann.
Meinen IPFire 2.19 (64-bit) - Core Update 105 kann ich vom Schülerserver
aus mit ssh -p 222 ipfire ohne Probleme ansprechen. Ich habe auch länger
als 5 Minuten gewartet (genauer gesagt: 35 Minuten) es hat sich trotzdem
nichts getan, Ein Neustart vom IP-Fire hat auch nichts gebracht.

wurde nach dem Einrichten des Netzes mal ein
linuxmsuter-ipfire --setup --first
gemacht?
Dabei werden auf dem IPFire ein paar EInstellungen gemacht.

Läuft ein
import-workstations
ohne Fehler durch?
Stehen die geblockten Schülerrechner mit MAK im Proxy des IPfire?
(geblockte Hosts).
Hast du subnetting?

… haha: jetzt hab ich eine Idee: schreib mal die IPAdressen der Cleints.
Sind die zufällig zwischen 10.16.1.100 und 10.16.1.200 ?

Viele Grüße

Holger

Hallo Holger,

  • linuxmuster-ipfire --setup --first wurde abgesetzt
  • import-workstations läuft soweit ich es sehen kann auch ohne Fehler durch.
  • Subnetting habe ich keins.
  • Die IPs liegen auch nicht zwischen 10.16.1.100 und 10.16.1.200
  • Beim IPfire liefert eine Suche bei: Netzwerk -> Web-Proxy -> Felder: gesperrte IP-Adressen und gesperrte MAC-Adressen leere Felder.

Viele Grüße
HAL

P.S.: Meine Vermutung liegt immer noch darin, dass mein “DNS-Problem” (siehe anderen Thread) die Ursache für dieses Problem ist. Ansonsten läuft alles soweit ich sehen kann korrekt.

Hallo Holger,

was ich nicht ganz verstanden habe ist:
Stehen die erlaubten/verbotenen Rechner mit Ihrer IP- oder MAC-Adresse im IPFire aufgelistet?

LG
Oliver

Hallo Oliver,

mit Ihrer IP- oder MAC-Adresse im IPFire augelistet

das ist abhängig von der Vesion der eingesetzen linuxmuster.net. Bis einschließlich Version 6.0 wurden MAC-Adresen eingetragen, ab Version 6.1 werden IP-Adressen eingetragen.
Zur technischen Umsetzung: siehe https://www.linuxmuster.net/wiki/dokumentation:techsheets:internetsperre#umstellung_bei_upgrade_von_linuxmusternet_60_auf_61

Grüße,
Sven

Hallo Oliver,

Hallo Holger,
was ich nicht ganz verstanden habe ist:
Stehen die erlaubten/verbotenen Rechner mit Ihrer IP- oder MAC-Adresse
im IPFire aufgelistet?

das bezog sich auf das Feld im IPFire, das du schon erwähnt hattest:
“Netzwerk -> Web-Proxy -> Felder: gesperrte IP-Adressen und gesperrte
MAC-Adressen.”

Wegen deines DNS Problems: da ist ja Jörg Richter dran: versuch mal das,
was er schreibt.

Ich vermute, dass der Regpatch (global.reg) nicht richtig installiert
wurde, weil Windows 10 in einer Domäne einem “normalen” DNS nicht mehr
traut: das muss abgeschlatet werden: eben durch den Regpatch.

Viele Grüße

Holger

Hallo Holger, Sven und alle Mitstreiter,

in diesen Feldern stehen bei mir weder verbotene noch erlaubte (außer der Server). Bin Mittwoch wieder an der Schule und werde mir das nähers anschauen.

Schöne Osterfeiertage
Oliver