Notebooks mit M2 SSDs -> Bluescreen beim Booten (winload.exe missing)

Hallo,

ich bin vor kurzem folgendem Problem begegnet:
Wenn ich bei einem Kunden neue Notebooks, die M2 SSDs haben, das gewünschte Windows 10 Image booten möchte, erhalte ich einen Bluescreen (winload.exe missing). Bootet man von einer manuell eingebauten Standard SSD, geschieht dies wohl nicht (konnte ich selber nicht testen - aber ich vertraue der Aussage). Das Image kann ich mit Workaround dann trotzdem booten, indem ich per Windows Boot Stick “bootrec /RebuildBcd” ausführe - ist aber keine Dauerlösung.

LiMu: 6.2.6
Linbo: 2.3.22-0

Kennt jemand ggf. den Fehler oder hat einen Tipp?

LG
Xandra

Hallo Xandra,

ich bin vor kurzem folgendem Problem begegnet:
Wenn ich bei einem Kunden neue Notebooks, die M2 SSDs haben, das
gewünschte Windows 10 Image booten möchte, erhalte ich einen Bluescreen
(winload.exe missing). Bootet man von einer manuell eingebauten Standard
SSD, geschieht dies wohl nicht (konnte ich selber nicht testen - aber
ich vertraue der Aussage). Das Image kann ich mit Workaround dann
trotzdem booten, indem ich per Windows Boot Stick “bootrec /RebuildBcd”
ausführe - ist aber keine Dauerlösung.

normalerweise: einfach nach bootrec /rebuildbcd
ein neues Image schreiben: fertig.

LiMu: 6.2.6
Linbo: 2.3.22-0

sind das nvme SSDs?
Ich würde sowiso empfehlen auf die aktuelle linbo Version zu gehen:
gerade das handling von gpt und nvme ist da besser geworden.

Viele Grüße

Holger

Hi Holger,

danke für die Infos, dann versuch ich das mal & schau wg. dem Linbo Update!
(Ja, sind nvme SSDs)

Grüße,
Xandra

Hi,

es kamen ein paar andere LiMu Themen dazwischen, daher jetzt erst ein Update:

Nach dem Linbo Update (auf 2.3.40-0, wenn ichs richtig in Erinnerung habe) konnten die anderen Rechner weiterhin normal gebootet werden, die neuen Notebooks mit NVME’s hingegen hingen im ‘Welcome to Linbo’ Bildschirm. Damit erstmal wieder alles läuft, hab ich ein Linbo Downgrade auf die alte Version durchgeführt - war dann auch wieder in Ordnung.

Das mit dem neuen Image erstellen wurde ebenfalls gemacht, allerdings müssen jetzt 2 Images gepflegt werden, da das neue Image nur an den Notebooks läuft und das ursprüngliche an den anderen Rechnern.

Muss ggf. beim Linbo Update in der Konfig etwas hart angepasst werden, damit Rechner mit NVME’s booten können?

Und hat noch jemand eine Idee, wie man die 2 Images vereinen kann, sodass es mit normalen SSDs und NVME SSDs läuft?

Grüße,
Xandra

Hallo,

Muss ggf. beim Linbo Update in der Konfig etwas hart angepasst werden,
damit Rechner mit NVME’s booten können?

ja.

Und hat noch jemand eine Idee, wie man die 2 Images vereinen kann,
sodass es mit normalen SSDs und NVME SSDs läuft?

bei mir läuft ein Image auf SATA SSDs und NVMe SSDs (Ubuntu: Windows
geht wahrscheinlich mal wieder nicht …).

Dazu hab ich im postsync zwei fstab hinterlegt:

SATA: in /var/linbo/linuxmuster-client/trusty/common/etc/fstab

/etc/fstab: static file system information

Hallo Holger!

Ich glaube du hast die code-Tags vergessen, da fehlt alles ab /etc/fstab: static file system information. Bitte nochmal.

Liebe Grüße

Thorsten

Hallo Thorsten,

Ich glaube du hast die code-Tags vergessen, da fehlt alles ab
/etc/fstab: static file system information. Bitte nochmal.

… grrr …

Dazu hab ich im postsync zwei fstab hinterlegt:

SATA: in /var/linbo/linuxmuster-client/trusty/common/etc/fstab

[code]

/etc/fstab: static file system information.

Hi Holger,

bei mir fehlt weiterhin alles ab /etc/fstab: static file system information.

LG
Xandra

Hallo Holger!

Schicke mir mal bitte eine Kopie deiner Mail ans Forum. Vielleicht finde ich das Problem mit der Darstellung.

Lieben Gruß

Thorsten

Hi nochmal,

Hatten beim Linbo Update nicht viel Zeit die Konfig zu prüfen & zu testen.
Welche Parameter müssen in der Linbo Konfig angepasst/gesetzt werden?

Würde mich nicht wundern, wenn Windows da Probleme macht…
Sobald ich aber Linbo erfolgreich upgedatet hab & alle Rechner booten, würde ich das nochmals testen.

Hallo,

in der start.conf muss nur aus allen
/dev/sdaX
/dev/nvme0n1pX
gemacht werden.
Danach import_workstations
und sicher stellen, dass auch die /var/linbo/boot/grub/.cfg
geschrieben wird: also "managed by linuxmuster.net Zeile nicht beschädigt ist.

LG

Holger

Hallo Thorsten,

Schicke mir mal bitte eine Kopie deiner Mail ans Forum. Vielleicht finde
ich das Problem mit der Darstellung.

hab ich schon gemacht … ich hab die “code zu tags” wohl falsch gemacht.
Hier nochmal:

Hallo Thorsten,

Ich glaube du hast die code-Tags vergessen, da fehlt alles ab
/etc/fstab: static file system information. Bitte nochmal.

… grrr …

Dazu hab ich im postsync zwei fstab hinterlegt:

SATA: in /var/linbo/linuxmuster-client/trusty/common/etc/fstab

[code]

/etc/fstab: static file system information.