Linbo 6.2 (ohne PXE) + kaputtes grub

Atheros-Chipsätze sind teilweise fehlerhaft programmiert oder unzureichend mit Speicher ausgestattet, das ist ja jetzt bekannt.

http://docs.linuxmuster.net/de/latest/release-information/knownbugs.html#fehlerhafte-atheros-chipsatze

Der LINBO-Bootstick hilft. Das ist scheinbar eine einmalige Sache. PXE-Boot wird für diese Rechner ausgeschalten.

ich hatte heute prompt den Fall, dass ein so ausgestatteter Laptop, der eignetlich funktionierte “auf einmal” nicht mehr bootete. Ich vermute stark: user-interaktion an irgendeiner STelle der Bootprozesse und darauf hin endet der Versuch, grub zu booten mit

could not load/find the file boot/grub/i386-pc/normal.mod
entering rescue mode
grub rescue >

Fazit: Ich habe wieder den LINBO-Stick gebraucht. Eine andere Möglichkeit sehe ich nicht. Wie man grub so zerschießen kann ist mir nicht bekannt.

vG, Tobias

p.s. mutwillig ist mir das nicht gelungen. Ich habe den Computer an verschiedenen Bootstellen abgeschossen und grub bootet weiterhin. Zum Zeitpunkt “installiere grub… ok” abzuschalten gelang mir vom Timing her nicht.

Hallo Tobias,

Fazit: Ich habe wieder den LINBO-Stick gebraucht. Eine andere
Möglichkeit sehe ich nicht. Wie man grub so zerschießen kann ist mir
nicht bekannt.

p.s. mutwillig ist mir das nicht gelungen. Ich habe den Computer an
verschiedenen Bootstellen abgeschossen und grub bootet weiterhin. Zum
Zeitpunkt “installiere grub… ok” abzuschalten gelang mir vom Timing
her nicht.

warum nicht?
Steckerleiste mit Schalter nach vorne führen und dann … klick …
Oder geht das so schnell durch?
Hast du nur mit dem ATX Powerschalter experimentiert?
Die Schüler an meiner Schule sind da zum Teil ganz anders drauf: da wird
direkt hinten am Stromkabel gezogen …

Keine Kritik: nur Gedanken zu “was machen Schüler mit den Rechnern wenn
keiner hinschaut …”

LG

Holger

Hi Holger,

ne, ist klar. Ich habe einen Laptop und hatte gestern nicht viel Zeit, Batterie raus - an einen Schalter etc. Das kann ich noch machen bei Gelegenheit.

update: mir ist es gelungen, das grub zu zerschießen. DAbei war ich im LINBO-GUI, es lief ein initcache oder ein sync und ich hab auf “reboot” gedrückt. Danach war sense, laptop bleibt im grub stehen.
ICh krieg noch raus, wann man genau nicht reboot drücken darf… das Ausgrauen + deaktivieren der schaltflächen wäre eine möglichkeit, die schon mal in einem Ticket landete, so viel ich weiß.
vG, Tobias