IPFire Core 131 funktioniert

#1

Hallo,
ich habe auf Core 127 aktualisiert und (bis jetzt) funktioniert alles…
LG
Max

#2

dito, inkl. subnetting.

auch ich hab jetzt mal

val-permissive-mode = yes

gesetzt, beim ersten Mal booten dauerte es mir echt zu lange und danach tat auch der DNS nicht, hab nochmal gebootet und dann tat er. Lag aber vermutlich nicht an dem update 127.
VG, Tobias

#3

Hallo,

ich habe auf Core 127 aktualisiert und (bis jetzt) funktioniert alles…

bei mir auch in einer virtualisierten Umgebung mit XEN 7.2.

Gruß

Alois

#4

Hier auch unter ESXi 6.0!

VG,
Jochen

#5

Hallo,
bin auf update 127 gegangen mit XCP-ng 7.6 virtualisiert. Es funktioniert soweit alles.
VG
Chris

#6

Hallo,

mittlerweile wird update 130 angeboten. Hat das schon jemand getestet?

Viele Grüße, Wilfried

#7

Hallo,

ich habe heute upgedatet und es scheint zu laufen.

Viele Grüße, Wilfried

#8

Ich habe von 127 auf 130 upgedatet. Workaround:

Core-Update 2.21
Release: 127 -> 130

Update: linux-pae
Version: 0 -> 4.14.103
Release: 0 -> 81

PAKFIRE RESV: linux-pae: Resolving dependencies...

PAKFIRE UPGR: We are going to install all packages listed above.
linux-pae-4.14.10... 100.00% |=============================>|   36.98 MB
PAKFIRE UPGR: linux-pae: Decrypting...
PAKFIRE UPGR: linux-pae: Upgrading files and running post-upgrading scripts...
PAKFIRE UPGR: linux-pae: Finished.

[screen is terminating]
Connection to 10.16.1.254 closed.
... upgrade failed, no connection to ipfire. Please run "linuxmuster-ipfire --upgrade" again.
10:55/1 server ~ # linuxmuster-ipfire --upgrade

###################################
# linuxmuster.net: IPFire upgrade #
###################################

ssh: connect to host 10.16.1.254 port 222: Connection refused
Cannot establish ssh connection to Firewall!

Die IPFire rebootete nicht automatisch, der ssh-daemon war aber weg.
Ich konnte mich aber über die Webkonsole anmelden, dort bei SSH-Zugriff auf “SSH-deamon in 15 Minuten beenden” anklicken und dann komm ich wieder rein…
Die Webkonsole sagt aber: Neustart nötig.

Jetzt habe ich nochmal

# linuxmuster-ipfire --upgrade

###################################
# linuxmuster.net: IPFire upgrade #
###################################

Passwordless ssh connection to Firewall is available.

IPFire 2.21 core 130 detected

IPFire needs a reboot before upgrading
Rebooting IPFire ...

Jetzt rebootet er… mal sehn ob er wieder hochkommt…
VG, Tobias

#9

Hallo Tobi!

Das hatte ich auch bei dem Update auf Core 129. Bei 130 lief es ganz problemlos durch.

Bisher keine negativen Reaktionen der User. (Was hat der Büttel da wieder gemacht?!)

Liebe Grüße

Thorsten

#10

Nachtrag: IPfire kam hoch.
Aber: Ich habe auf einmal von meinem dockerhost nicht mehr ins Internet gekonnt.
Ich denke, das sollte eigentlich bisher von der regel “allowedhosts” -> ROT: allowed_ports erledigt worden sein. Aber seit dem reboot kam ich nicht mehr ins Internet.
Jetzt musste ich eine extra Regel anlegen… seltsam.

#11

Hallo!
bis jetzt scheint alles zu funktionieren, den DNSSEC musste ich jedoch wieder abstellen, sonst nimmt er den Jugendschutz-Belwü-DNS nicht…
LG
Max

#12

Update von 127->130 funktioniert (xcp-ng 7.6). Danach keine Auffälligkeiten.
VG
Chris

#13

Bei mir ebenfalls

Gruß Alois

#14

Ich habe lmn.net 6.2 mit IPfire Core 130 aufgesetzt und bei import_workstations bisher immer die Fehlermeldung

  • Reloading external firewall …
    … failed!

erhalten. Auf den Fehler wird auch am Ende hingewiesen (Finished with errors!…).
Ist das ein Bug – und liegt das evtl. an Core 130?

VG, Josef

#15

Hallo Josef,

nein, das liegt vermutlich daran, dass der IPFIRE nicht passwortlos vom Server erreicht werden kann.

Probier mal auf der Konsole des Server folgendes:

ssh -p 222 ipfire

oder mit der IP-Adresse

ssh -p 222 10.16.1.254

wenn Du ohne Eingabe eines Passwortes auf die Konsole des IPFIRE kommst, dann ist alle ok. Ich vermute aber, dass das nicht klappt.

Wenn das nicht klappt, dann führe auf dem Server folgenden Befehl aus:

linuxmuster-ipfire --setup --first --password=

Nachdem das Skript durchgelaufen ist wird der IPFIRE neu gestartet und der passwortlose Zugriff sollte möglich sein.

Gruß

Alois

#16

Hallo Alois,
danke für die schnelle Hilfe! Kam dadurch drauf, dass ich beim IPfire den Haken bei Standardport 22 gesetzt hatte – natürlich entgegen dem Screenshot der Firewall-Installationsanleitung… (Konfiguriert ist IPfire aber…)

Besten Dank!
Josef

#17

Hi,
dieses Mal ist update von core 130 auf 131 kein THema.
VG, Tobias